Home  >  Support  >  Support Forum  >  Xbee S1 not reading in X-CTU (Sparkfun USB explorer)
Notice! We've recently migrated to using a new forum, we hope you enjoy it. If you are an existing member and this is your first time visiting our new forum, please reset your password to be able to sign in.

Xbee S1 not reading in X-CTU (Sparkfun USB explorer)

0 votes
I recently got two Xbee S1 modules running on XBEE 802.15.4 Version 10EC.

I use the XBee Explorer USB from Sparkfun (Xbee USB Explorer)

I followed this guide in order to set up my XBee (XBee set up tutorial I followed)

The XBee was fine and readable up until i changed PAN ID to: 3264. DL to 6738. MY to 5748. All done in Netoworking & Security. I followed all the steps in the guide and updated firmware before changing modem configuration. Finally I click write and the XBee becomes unreadable and will not be recognized at any Baud rate regardless of API enabling.

I have tried different ways to rewrite the firmware but no luck
Ways I've tried:
Restoring broken Xbee
Other restoring method.
Another restore method used

The USB explorer is not at fault here because my other XBee reads just fine. I have also gone and soldered myself a reset button on the explorer to get past action required screen

When I try and rewrite the firmware normally X-CTU messages this:
"Getting modem type....Programming modem...OK
Failed to enter command mode
Found bootloader active reprogramming firmware.
Write Parameters...Failed"


When trying one of the above restore methods I get the action required page one time and then the second time near the end pops up and asks for the reset button, but no matter how many times I make a connection the screen doesn't go away.

Terminal in X-CTU also does not respond to +++

Any help would be greatly appreciated willing to do anything to get this sucker going again.
asked Apr 24, 2013 in IEEE 802.15.4 by Djip New to the Community (3 points)
I've just encountered the same thing with a XBee Pro S2B on a DFRobot XBee USB Adapter V2.

I could talk to it fine and then I did a "Download new versions" and then a "Write" in X-CTU and now it won't respond.

Did you manage to get back in touch with it somehow?
I registered just to thank you so much for this, thank you thank you thank you

i am used same way but with few difference
i am will write the steps below

1. Connect Sparkfun USB Explorer (Without X-CTU running) Your XBee should be plugged ......Carefully plug in your Xbee into the usb explorer .

2. On the Sparkfun Explorer I soldered wires to RST and GND on the side close to the USB Plug in. Plug these wires on a bread board together.

3. Start X-CTU and in PC Settings make sure to set Baud to 9600. Flow Control: Hardware. Other settings shouldn't be touched.

4. Go to Modem Configuration (I was using an XBee series 1)
a) Set Modem to the Xbee you are using (mine was XB24) Function set should be first one and select latest version
b) Next hit Show Defaults (crucial part since this is what was my problem... Hehe)
c)  Update Firmware checked " i am tried  Update Firmware unchecked but i am cant to solve problem but when Update Firmware checked the problem has solved"

5. Hit Write ( A reset window should pop up. This is what you want)

6."tx" light will become flasher ( A reset window should pop up) in this moment take out the wires you put into a breadboard ( A reset window should hiden) and "loading line appear "  after few moments ( A reset window should pop up) pu the wires you put into a breadboard between (GND and RST) ( A reset window should hiden) in this moment take out the wires you put into a breadboard "loading line appear "  and the xbee update  finshing .

7.Let it finish writing and you should now have a working XBee radio. Restart X-CTU and you should now be able to read the XBee.

Tips: You might get errors such as Flash Checksum Error or Failed to enter Command mode or Detected Baud rate Difference. I have gotten them many times, but just keep trying these steps until it goes through. If done correctly it should fix your XBee. The video I linked really helped me out aswell and applies to all explorers you might be using not just a Sparkfun USB explorer.

Please log in or register to answer this question.

3 Answers

+1 vote
Found the answer to my problem. If anyone still wondering i followed these steps with a sparkfun usb explorer

Recovery processes video i followed

Make sure you have the latest X-CTU software

Steps:
1. Connect Sparkfun USB Explorer (Without X-CTU running) Your XBee should not be plugged in at the moment

2. On the Sparkfun Explorer I soldered wires to RST and GND on the side close to the USB Plug in. Plug these wires on a bread board together.


3. Start X-CTU and in PC Settings make sure to set Baud to 9600. Flow Control: Hardware. Other settings shouldn't be touched.

4. Go to Modem Configuration (I was using an XBee series 1)
a) Set Modem to the Xbee you are using (mine was XB24) Function set should be first one and select latest version
b) Next hit Show Defaults (crucial part since this is what was my problem... Hehe)
c) Leave Always Update Firmware Unchecked


5. Hit Write ( A reset window should pop up. This is what you want)

6. Carefully plug in your Xbee now into the usb explorer.

7. Once plugged in take out the wires you put into a breadboard or held together.

8. Let it finish writing and you should now have a working XBee radio. Restart X-CTU and you should now be able to read the XBee

Tips: You might get errors such as Flash Checksum Error or Failed to enter Command mode or Detected Baud rate Difference. I have gotten them many times, but just keep trying these steps until it goes through. If done correctly it should fix your XBee. The video I linked really helped me out aswell and applies to all explorers you might be using not just a Sparkfun USB explorer.
answered May 6, 2013 by Djip New to the Community (3 points)
edited May 6, 2013 by Djip
I registered just to thank you so much for this, I was tearing my hair out having "bricked" two brand new series 1 Xbees, and after much googling your instructions were the only ones that worked. Thanks again!
0 votes
Hello Djip,

Just a thougth, check that your XBee Explorer does drives the Serial port's hardware flow control lines (specially DTR and RTS). You can test this with X-CTU and a multimeter. In any case, it's a very strange case.
answered Apr 25, 2013 by spastor Veteran of the Digi Community (394 points)
0 votes
I have the same problem with 2 boards !
could you solve it ?

Do you think it's a software or a hardware problem ?
answered May 2, 2013 by gegebelzebuth New to the Community (1 point)
Contact a Digi expert and get started today! CONTACT US
...