Home > Support > Knowledge Base > Knowledge Base Article

LxNETES-3.2 make xconfig might fail with message like:
linux/scripts/kconfig/qconf.h: error: extra qualification ' ConfigSettings::' on member 'readSizes'
..
make: *** [xconfig] Error 2

Modern Linux distributions use Qt 4.4.3 or higher and don't allow to downgrade (without major problems) to a version which does work with the old "xconfig" of Linux kernel 2.4.22.

Workaround: use "make menuconfig"

For menuconfig you might need to install some package including ncurses.

Contact a Digi expert and get started today! CONTACT US

Desktop Site