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Introduction to Digi Port Authority-Remote

DPA - Remote (Digi Port Authority - Remote) is a program used to discover andmonitor data and
errors on Digi devices with either Digi’s proprietory program called ADDP (A Digi Discovery Protocol) or
SNMP agents over TCP/IP. A network interface to a device might be an Ethernet or PPP connection.

Discovery
Discovery is a program that discovers Digi devices residing on a network. The Digi devices are
discovered with either ADDP (A Digi Discovery Protocol) or SNMP.
ADDP
For a Digi device to be discovered by ADDP, it must be ADDP-enabled. ADDP runs on any operating
system capable of sending multicast IP packets on a network. It allows the system to identify all ADDP
enabled Digi devices attached to a network by sending out a multicast packet. The Digi devices
respond to the multicast packet and identify themselves to the client sending the multicast. The ADDP
protocol needs to communicate with the TCP/IP stack using the UDP protocol. The TCP/IP stack
should be able to receive multicast packets and transmit datagrams on a network. Not all Digi devices
support ADDP.
SNMP
For a Digi device to be discovered by SNMP, it must have SNMP enabled. An SNMP agent must be
running on your supported Digi device before you can use DPA - Remote to monitor it. To start the
SNMP agent, see the appropriate documentation for your particular Digi device.

Network Interface Monitoring
Monitoring a network interface can be helpful in troubleshooting network performance issues or
keeping track of the network interface performance. DPA-Remote can monitor incoming and outgoing
data and errors on a network interface. See Monitor network interfaces.

Port Monitoring
Monitoring ports can be helpful in troubleshooting port problems. DPA-Remote can monitor incoming
and outgoing data and errors on ports. Also, individual signals (such as DTR, DCD, OFC, IFC, etc.) can be
monitored. By viewing port signals, a user may be able to determine if a port appears to be
functioning correctly or if it appears to be in some state of flow control or other condition of concern.
See Port Monitor fields and graphs.
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PortServer Products Supported
DPA-Remote supports Digi One RealPort, PortServer II, and PortServer TS products. Where this
documentation uses the name PortServer, this implies any of these supported PortServer products.
The original Digi PortServer is not supported.

Note Depending on your PortServer model and firmware revision, the information displayed by DPA-
Remote may differ.

Hardware requirements

Using the Keyboard Instead of a Mouse
The DPA - Remote utility includes keyboard support for users with no access to a mouse or a
preference for a keyboard. However, not all operating systems support these functions.
The TAB, SHIFT-TAB and arrow keys can be used to navigate the interface. Also available for use are
the "ALT" keystroke combinations. For example, ALT-F will bring up the File menu and ALT-O brings up
the Options menu from the main monitoring window.



Get started

Follow these steps to download and install DPA-Remote, launch the application, and configure and
monitor a device.

1. Download DPA-Remote.

2. Install Digi Port Authority-Remote.

3. Start DPA-Remote.

4. Configure a device in DPA-Remote.

After you have discovered devices from DPA-Remote, you can monitor network interfaces and ports,
and display information about your device in the Device Monitor.

n Monitor network interfaces

You can also configure the DPA-Remote application.
n Configure DPA-Remote

Download DPA-Remote
1. Go to the product support page for your device.

2. Choose Diagnostics, Utilities and MIBs.

3. From the Operating System Specific Utilities list box, select your operating system.

4. Download the appropriate version of the utility and save it to the desired directory.

Install Digi Port Authority-Remote
You can install DPA-Remote on your device using any of these methods.

Prerequisites
n On UNIX installations, an X-Window environment must be installed in order to run DPA-Remote.

n On all installations, a web browser is required in order to display the help.

n You must have downloaded the DPA-Remote software.

n Linux users must create symbolic links before DPA-Remote will install properly. This step is
included in the Linux install processes.

From the list below, select the appropriate OS:
n Install on Linux (RPM method)

n Install on Linux (from source)
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Install on Linux (RPM method)
1. Place the downloaded distribution file in a directory, such as /usr/src.

2. Verify that the directory exists:

/usr/src/linux

If it does not exist, create a symbolic link by entering the following command:

ln -s /usr/src/linux-(version number) /usr/src/linux

Where version number is the number of the Linux kernel.

3. All Linux versions except RedHat must create the following symbolic link for the RPM to install
properly. Enter the following command:

ln -s /usr/src/(RPM source directory) /usr/src/redhat

Where the RPM source directory is the specific name used by your Linux distribution.

4. Enter the following commands:

rpm -ivv 40002188_version.src.rpm
cd /usr/src/redhat/SPECS
rpm -bb digidpar-version.spec
cd /usr/src/redhat/RPMS/<arch>
rpm -ivv digidpar-version.<arch>.rpm

Install on Linux (from source)

Note You should not remove the source tree, since the makefiles are necessary for the uninstall
procedure.

1. Place the downloaded distribution file in a directory, such as /usr/src.

2. Verify that the directory exists:

/usr/src/linux

If it does not exist, create a symbolic link by entering the following command:

ln -s /usr/src/linux-(version number) /usr/src/linux

Where version number is the number of the Linux kernel.

3. All Linux versions except RedHat must create the following symbolic link for the RPM to install
properly. Enter the following command:

ln -s /usr/src/(RPM source directory) /usr/src/redhat

Where the RPM source directory is the specific name used by your Linux distribution.
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4. Enter the following commands:

cd /usr/src

tar -xvzf 40002188_version.tgz

cd digidpar-version/sme

make install

make link

Start DPA-Remote

Linux
1. Enter the following command: dparemote

2. The main window appears.



Configure a device in DPA-Remote

Within DPA-Remote, you can access your devices that have been discovered by DPA-Remote.

Note Each time you access a device from DPA-Remote to configure the device, a log in screen for that
device appears and you are required to log in to the device.

1. Start DPA-Remote.

2. In the Device Configuration area, enter the DNS name or the IP address of the device. You can
also choose a device from the Discovered Devices or Most Recent lists.

3. Choose Configure. A log in dialog displays.

4. Enter the user name and password.
n User name: root

n Password: Enter the default password printed on the device label. If a password is not
on the label, the default password is dbps. If neither password works, the password
may have been changed. Contact your system administrator.

5. The device's web interface opens, from which you can configure your device. Refer to the
configuration manual for your device for information about the configuration fields.
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Monitor network interfaces

In the Device Monitor, you can monitor network interfaces and ports, and display information about
the devices that you have discovered using DPA-Remote.

1. Start DPA-Remote.

2. In the Device Monitor area, enter the DNS name or the IP address of the Digi device. You can
also monitor a device by choosing a device from the Discovered Devices or Most Recent lists.

3. From the Community list box, choose the appropriate device community. Options are:
n Public: The device's default community for read-only access. If this has been changed in

the device configuration, choosing this option will not have the desired effect, and you
must instead choose the <user-defined> option and enter the appropriate community
name.

n Private: The device's default community for read/write access. If this has been changed
in the PortServer, choosing this option will not have the desired effect, and you must
instead choose the <user-defined> option and enter the appropriate community name.

n <user defined>: Custom read or write access as defined on the device. This requires
that the SNMP community entered has been previously defined on the device being
monitored.

4. Choose Monitor. The main Device Monitorwindow appears. If an error occurs when DPA-
Remote is attempting to connect to the device, a message appears.

5. Choose the Display Information tab to view information about the Digi device.

6. Choose the Network Interface and Ports tab to view the network interface and ports.
Multiple interfaces and ports may be selected at the same time. See DPA-Remote main
window (Control Panel).

A new monitor frame appears for each network interface or port you select. To close a monitor
frame, click the network interface or port button associated with that frame.

7. Monitor the network interfaces or ports.

8. If your device supports Modbus, you can choose Modbus Information to view information
about the Digi Modbus device. This tab is not available on systems that do not support Modbus.
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Configure DPA-Remote

The topics in this section explain how to configure DPA-Remote.

Configure the Device Monitor 13
Configure the ADDP discovery process 13
Configure the SNMP discovery process 13
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Configure the Device Monitor
Fonts, timers, and graph scaling can be modified for the Device Monitor.

1. Start DPA-Remote. The main window displays.

2. Choose File > Options > Device Monitor.

3. Change the fonts, timers, and graph scaling as desired.

4. Save the changes.

Configure the ADDP discovery process

Configure DNS names display (ADDP)

Note This process is for ADDP only.

1. Start DPA-Remote.

2. In the main window, select File > Options.

3. Select the General Options tab.

4.  Manage the Enable name resolver option.
n Select: The DNS names display, but this may slow the discovery process on Microsoft

Windows systems.

n Deselect: Do not display DNS names. This improves system performance.

5. Save the changes.

Configure auto-discover devices on start up (ADDP)

Note This process is for ADDP only.

1. Start DPA-Remote.

2. Select the Discovery Options tab.

3.  Select Auto Discover.

4.  Select Pre-select ADDP discovery.

5. Save the changes.

Configure the SNMP discovery process

Configure the SNMP throttle value

Note This process is for SNMP only.

1. Start DPA-Remote.

2. In the main window, select File > Options.
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3. Modify the detection of the local subnet.
a. Select the Discovery Options tab.

b. Set the SNMP Throttle. The SNMP Throttle controls the number of SNMP requests
made per second on the network. Setting the SNMP Throttle too high may
overwhelm the network and seriously hinder network performance.

4. Save the changes.

Configure the SNMP discovery IP address range
Modify which IP addresses or range of IP addresses on which an SNMP discovery search should be
made.

Note This process is for SNMP only.

1. Start DPA-Remote.

2. In the main window, select Discovery Protocol.

3. Select SNMP.

4. Select Criteria.

5. Save the changes.



Uninstall Digi Port Authority-Remote

You can uninstall DPA-Remote from your device.
n Uninstall from Linux (RPM method)

n Uninstall from Linux (from source)

n

Uninstall from Linux (RPM method)
1. Enter the following command:

rpm -e digidpar

Uninstall from Linux (from source)
1. Enter the following commands:

cd /usr/src/digidpar-version/sme

make unlink

make uninstall
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DPA-Remote main window (Control Panel)
When you start DPA-Remote, the main window displays.

Control Panel

Item Function

Device Monitor Choose Device Monitor to monitor interfaces and ports on Digi
devices.

Device Configuration Choose Device Configuration to launch a browser and configure
your Digi device with the Web interface, provided this feature is
supported on your device.

Most Recent The Most Recent field contains a list of the IP addresses or DNS
name of the most recent devices
monitored or configured with DPA-Remote.
You can change the length of the list.

1. In the main window, select File > Options.

2. Choose the General Options tab.

3. Use the buttons to increase or decrease the number of
devices listed.

Discovered Devices Display all the devices discovered by either the ADDP or the
SNMP protocol.
You can modify the discovery process for both ADDP and the
SNMP protocols. See Configure the ADDP discovery process.

Discovery Protocol Choose either ADDP or SNMP to discover devices attached to
your network.
ADDP: ADDP allows the system to identify all the Digi devices
attached to a network by sending out a multicast packet. If a
Digi device has ADDP it will respond to the multicast packet and
identify itself to the application sending the multicast.
SNMP: An SNMP agent must be running on your supported
PortServer device before you can use DPA-Remote to discover it.
SNMP Discovery sends an SNMP request to each node, but
throttles the speed at which the packets are sent out to prevent
your network from being flooded with requests. When the SNMP
protocol is selected, the Criteria button becomes available and
allows modifications to the SNMP discovery search.

Discover Launch another search for devices using either ADDP or SNMP
protocols.

Save Save a list of discovered devices.

Criteria The Criteria button appears when the SNMP option is selected.
Click Criteria to modify SNMP Discovery requests.

Clear Item Clear a single highlighted device from the Discovery Devices list.

Clear All Clear all devices from the Discovery Devices list.
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File > Options menu options

Item Function

Global Allows the user to change location of program data, modify Most
Recent list, and enable/disable Domain Name Resolver.

Discovery Modify the Discovery options such as SNMP Throttle.

Device Monitor Modifies font sizes, timers, and graph scales displayed by the
Device Monitor.

Monitor window
To access this screen, choose Monitor from the Device Monitor field on the Control Panel.
To close this screen, use the ESC key.

Field Description

Device Name The name of the device, if defined.

Node The node name or IP address of the device.

Device Description Describes the device. The description may include the
firmware version of the device.

Variable Power Fields Two power sources are available, either Powered
Ethernet or an external power supply. The options are
engaged or disabled.

Processor Utilization
(PortServer TS 8/16 only)

The Processor Utilization graph shows the current CPU
utilization as a percentage.

n 100% indicates completely busy.

n 0% indicates completely idle.
The graph is updated from the right, at the interval
defined inOptions > Poll Interval.

Memory
Utilization
(PortServer TS 8/16 only)

The Memory Utilization graph shows the current CPU
utilization as a percentage.
100% indicates all available memory is being used.
The graph is updated from the right, at the interval
defined inOptions > Poll Interval.
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Port Monitor fields and graphs

Port Monitor fields

Field Description

Type The type of port selected.

Speed The speed of the port in bits per second.

Input Flow Control The input flow control of the port.
Examples: none, xonXoff or ctsRts

Output Flow Control The output flow control of the port.
Examples: none, xonXoff or ctsRts

Character Bits The number of bits in a character.
Examples: 8 or 7

Stop Bits The number of stop bits.
Examples: one, two or oneAndHalf

Parity The type of parity.
Examples: none, odd or even

Parity Errors The total number of characters with a parity error, input
from the port since system re-initialization and while the
port state was 'up' or 'test'. This field will show a red
background if an error has occurred in the last poll
interval.

Overrun Errors The total number of characters with an overrun error,
input from the port since system re-initialization and
while the port state was 'up' or 'test'. This field will show
a red background if an error has occurred in the last poll
interval.

Framing Errors The total number of characters with a framing error,
input from the port since system re-initialization and
while the port state was 'up' or 'test'. This field will show
a red background if an error has occurred in the last poll
interval.

MEI Settings Displays the devices MEI settings, usually on port 1 only.

Total Characters In The total number of characters received by the port.

Total Characters Out The total number of characters transmitted by the port.

Signal Monitor
This section of the port monitor window shows the status of various EIA-232 signals on the
selectedport. Active (on) signals are shown in green and inactive (off) signals in black.
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EIA-232 Signal Descriptions

Signal Description

RTS Request to send

CTS Clear to send

DSR Data Set Ready

DCD Data Carrier Detect

DTR Data Terminal Ready

RI Ring Indicator

OFC Output is Flow Controlled

IFC Input is Flow Controlled

Characters In/Octets Out Monitor
The Character In/Character Out graphs show the number of characters received (Characters In) and
transmitted (Characters Out) by the port. The graphs update from right-to-left and represent the
percentage of line speed over the last 20 poll intervals. The poll interval determines how frequently
the port is polled for information. Poll intervals apply to all data, not just graphs.

Network Interface Monitor fields and graphs

Interface Information fields

Field Description

Description A text string containing information about the interface.
This string usually includes the name of the
manufacturer, the product name and the version of the
hardware interface.

Physical Address The address of the interface at the protocol layer
immediately below the network layer in the protocol
stack. For interfaces that do not have such an address,
such as a serial line, this object should contain an octet
string of zero length.

Speed The speed of the network interface in bits per second. For
interfaces that do not vary in bandwidth or for those
where no accurate estimation can be made, this object
should contain the nominal bandwidth. A PPP connection
will report a speed of zero until the connection is up.
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Field Description

MTU The size of the largest datagram which can be
sent/received on the interface, specified in octets. For
interfaces that are used for transmitting network
datagrams, this is the size of the largest network
datagram that can be sent on the interface.

Input Counter fields

Field Description

Unicast Packets The number of input unicast packets received. Unicast is
the method by which a packet is sent to a single
destination.

Non-Unicast Packets The number of non-unicast (subnetwork-broadcast or
subnetwork-multicast) packets received.

Total Octets in The total number of octets received on the interface,
including framing characters.

Discarded Packets The number of inbound packets which were discarded.
One possible reason for discarding packets is to free up
buffer space. This field will show a red background if an
error has occurred in the last poll interval.

Packet Errors The number of received packets containing errors. This
field will show a red background if an error has occurred
in the last poll interval.

Unknown Protocols The number of packets received via the interface which
were discarded because of an unknown or unsupported
protocol.

Output Counter fields

Field Description

Unicast Packets The number of output unicast packets sent. Unicast is the
method by which a packet is sent to a single destination.

Non-Unicast Packets The number of non-unicast (subnetwork-broadcast or
subnetwork-multicast) packets sent.

Total Octets Out The total number of octets sent on the interface,
including framing characters.
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Field Description

Discarded Packets The number of outbound packets which were discarded.
One possible reason for discarding packets is to free up
buffer space. This field will show a red background if an
error has occurred in the last poll interval.

Packet Errors The number of sent packets containing errors. This field
will show a red background if an error has occurred in the
last poll interval.

Octets In/Octets Out Monitor
The Octets In/Octets Out graphs show the number of octets received (Octets In) and transmitted
(Octets Out) by the interface. The graphs update from right-to-left and represent the percentage of
line speed over the last 20 poll intervals.
The scale of the graphs can be changed by choosing Options > Graph Scale > Network from the
Monitor Windowmenu.
The poll interval of the graphs can be changed by choosing Options > Poll Interval from the Monitor
Windowmenu. The valid range is from 1-60 seconds. The poll interval determines how frequently the
interface is polled for information.



Troubleshooting

DPA-Remote connection errors
During the course of connecting to or monitoring a device, error windows may appear if DPA-Remote
cannot properly communicate with the device. These errors may point to a problem with the device or
the network connection between the device and DPA-Remote. The device may simply be powered off
or disconnected from the network.
If you get a connection error, verify these things.

n The IP address you specified is correct for the device.

n The IP address for the device is unique on your network.

n The device is poweredmon and properly connected to your network.

n You can ping or telnet to the device.

n The SNMP daemon is running on your device.

n The value in the community field you use (when selecting a device to monitor) matches the
actual read or write community value defined on the device.

If DPA-Remote cannot discover your device, it can be due to one of following reasons:
n The Digi device may have old firmware.

n ADDP or SNMP may not be supported on the device.

n There may be a network problem.
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