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Using this guide

About this guide
This guide describes NET+OS with Green Hills and how to use it as part of the development
cycle. Part of the NET+OS integrated product family, NET+OS is a network software suite
optimized for the NET+ARM.

Who should read this guide
This guide is for software engineers and others who use NET+OS. To complete the tasks
described in this guide, you must:


Be familiar with installing and configuring software.



Have sufficient user privileges to do these tasks.



Be familiar with network software and development board systems.
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Conventions used in this guide
This guide uses several typographic conventions:
Convention

Used for

italic type

Emphasis, new terms, variables, and document titles.

bold type

Menu commands, dialog components, items on the screen; filenames,
pathnames, and commands. In most cases, software release information is
not included with the filenames and pathnames; for example, C:\netos\
instead of C:\netos72\.

menu name > option

Menu commands. The first word is the menu name; the words that follow
are menu selections.

monospaced type

Code and command examples.

Software release level assumed in this guide
Instructions in this guide assume that NET+OS is installed in the default installation directory,
C:\netos. The software release level is displayed in the numbers that follow netos, for
example, C:\netos72.
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Related documentation
NET+OS online help describes the application programmer interfaces (APIs) that are provided
with NET+OS. The online help is located in C:\netos\docs.
For information about third-party products and other components, review the documentation
CD-ROM in the development kit.
For information about the processor, see the NET+OS hardware documentation.

Documentation updates
Digi occasionally provides documentation updates on the Web site.
If there are differences between the documentation received in the NET+OS package and the
documentation on the Web site, the Web site content is the latest version.

www.digi.com

n n n n n n n

11

Introduction
This document provides a series of tasks in which you:


Install Green Hills software.



Install NET+OS software.



Install the Digi JTAG Link debugger software.



Install the license for the Digi JTAG Link debugger software. If using the Majic debugger instead,
instructions are included in several appendixes.



Request and install a license for the Green Hills software.



Configure the IP address for the development board.



Complete a brief exercise that demonstrates how to use the tool set, including:
- Building the board support package (BSP), libraries, and template applications
- Running and debugging the sample application

Do the all the tasks in this guide in the order presented.

n
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Note Plan to spend approximately two hours completing the
tasks in this document. The exact time depends on the
speed of your PC and how long it takes to get a license key
from Green Hills.

The exercise
Task 1: Getting ready

Save files and close applications

Verify hardware requirements

Before performing the rest of the tasks
in this document several preparation
tasks are necessary.

The Green Hills and NET+OS software
installation requires rebooting the PC.
Safe all open files and close any open
applications before installing the
software.

Verify that the PC is running either
Microsoft Windows 2000 or XP.

The instructions in this document
assume that hardware is already
installed.

Verify access rights
Make sure you have administrative
rights on the PC on which Green Hills
and NET+OS software are installed.

14
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Windows 95/98/ME and Windows NT
4.0 are not supported.

What’s next?
Go on to the next task, installing Green
Hills software.

Task 2: Install Green Hills MULTI IDE
Software
Before installing NET+OS, it is required to install The Green
Hills MULTI IDE version 4.05. This software is available from
Green Hills Software at
http://www.ghs.com/products/MULTI_IDE.html.

What’s next?
When MULTI IDE software is installed, go on to the next task,
installing NET+OS software.

www.digi.com
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Task 3: Install NET+OS software
This task installs the NET+OS software on your system, using
a wizard.

About the installation
During the installation, if registering NET+OS, a serialnumber prompt is displayed. Use the serial number located
on the development board. If the development board is not
available, use Vnnnnnnnn.

16
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X To begin the NET+OS installation:
1

Place the installation CD in the CD drive, and follow the
wizard prompts.

2

On the Install Method screen, select Advanced Install
and continue with the wizard.

3

On the Select Development Environment and
Additional Debuggers page, select Green Hills MULTI
support for NET+OS. If not using the Digi JTAG Link
debugger, select the desired debugger. Note that Digi
ESP for NET+OS is not needed. Then continue following
the wizard until NET+OS is installed.

What’s next?
Go to the next task to obtain a Green Hills license.

www.digi.com
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Task 4: Request a Green Hills software license
key

About the Green Hills license keys

This task requests a license key for the Green Hills software.



An evaluation (temporary) key, which allows access to
the Green Hills MULTI software for 30 days.



A permanent key.

If upgrading from a prior NET+OS/Green Hills installation, a
Green Hills license is not necessary. Skip to “Task 7:
Configure the IP address of the development board” on
page 30.

Before using the Green Hills MULTI software, request and
install a software license key. Request either:

Digi strongly recommends requesting both license types at
the same time. An evaluation license key allows immediate
use of the software, while acquiring a permanent license key
can take up to 15 business days.
The MULTI Licensing Wizard creates a license request that can
be e-mailed, faxed, or mailed to Green Hills. The wizard
prompts for information such as:


The number of licenses desired.



Whether the license is computer-locked or donglelocked.



The type of computer on which the software is used.



Whether the license key is an evaluation (temporary) or
permanent license.

The license key is sent to your e-mail address.
18
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About license types

Requesting a license

Two license types are available:

1

Computer-locked. A computer-locked license must be used
on the PC from which the license was requested.

Click the MULTI icon on the desktop.
The MULTI Launcher opens:

Dongle-locked.A dongle-locked license, requires
attaching the dongle to the PC before beginning the
license request procedure.

www.digi.com
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Because you do not yet have a license, a warning
pop-up window also opens:

2

20

To continue, click OK in the pop-up window.

n n n

n n n n

The MULTI Licensing Wizard opens:

In addition, a warning pop-up window from the
MULTI License Administrator opens:

3

4

In the MULTI Licensing Wizard, click Request a license
from Green Hills. Then click Next.

To continue, click OK in the pop-up window.

www.digi.com
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This window opens:

5

22

Click Create a license request to e-mail, fax, or mail,
then click Next.

n n n

n n n n

The License Request Generator opens with this
form:

6

Fill in the form, leaving the GHS User ID (if known) field
blank, then click Next.

e Click Next.

The License Request Generator window opens:

This window opens:

7

Do these steps:

a Enter the number of licenses desired.
b Under License Availability, click the type of license
desired.
c Do not click Host Managed: license distributed by an
LM running on this computer.

8

Under License Type, click Evaluation, then click Next.
The Green Hills Software 30-day license agreement opens.

9

Review the license agreement, and click Yes.
The License Request Generator window opens.

d Select the computer type.
www.digi.com
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If the License Request Generator window does not
open, this dialog is displayed:

This message indicates that the dongle was not
connected.
Connect the dongle and click Retry in the
Dongle Not Found dialog.

24
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If the License Request Generator does not return a
copy of the license request (shown next), stop and
call Digi Technical Support.

10 Review the information in the license request to make
sure it is correct. Then, do either of these steps:

-

If the PC from which the request is made has e-mail,
click Send.

-

If the PC from which the request is made does not
have e-mail, click Save to File. Go to a system that
has e-mail and send the request as an attachment to
license@ghs.com.

11 In the License Request Generator, click Finish.

What’s next?
Within an hour, an e-mail message should be received that
either:


Includes the license key file and installation instructions.



Indicates that manual processing is required. Call Digi
Technical Support.

Go on to the next task, in which the license key is saved to the
PC.

12 In the MULTI Licensing Wizard, click Quit.
13 Exit from the MULTI Launcher.
14 To request a permanent license, repeat this task, but at
step 8, click Permanent for the license type.

www.digi.com
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Task 5: Save the license key

What’s next?
Go on to the next task to install the Green Hills license.

When the e-mail message is received from Green Hills, save
the attachments to a folder on the PC on which the license
should be installed.

26
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Task 6: Install the Green Hills license key

X To install the evaluation license key:
1

This task installs the evaluation license key received by
e-mail from Green Hills.

Double-click the MULTI icon on the desktop.
The MULTI Launcher opens:

When the permanent license is received, follow the
directions provided by Green Hills with your license. To
launch the MULTI Licensing Wizard from the MULTI Launcher,
select Utilities > License Administrator.

Because you do not yet have a license, this pop-up
window opens:

www.digi.com
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2

To continue, click OK in the pop-up window.
The MULTI Licensing Wizard opens, and this message is
displayed:

If the MULTI Launcher window was not closed, a
prompt is displayed to close all MULTI windows.
Close the other MULTI windows, and click Next in
the MULTI Licensing Wizard.
The Choose License File dialog opens:

3

Click OK.

4

In the MULTI Launcher window, select
File > Close Launcher.
The MULTI Licensing Wizard remains open.

5

28

In the MULTI Licensing window, click Install a license
which I already have, then click Next.

n n n

n n n n

6

Browse to the license file, select it, and click Install.

The Update Licenses window opens:

This window opens:

The installation takes a few minutes. This window
remains open during the installation process and
does not require any action.

7

If error messages appear in the Update Licenses window,
contact Digi Technical Support. Otherwise, click Close.

8

In the MULTI Licensing Wizard, click Quit.

What’s next?
Go on to the next task to configure the development board’s
IP address.

www.digi.com
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Task 7: Configure the IP address of the
development board

X To configure the IP address of the development board:
1

Do one of these steps:

-

Windows XP systems. Select Start > All Programs >
NET+OS Green Hills > HyperTerminal Connection,
and, depending on the port to which the
development board is connected, either COM1 or
COM2.

-

Windows 2000 systems. Select Start > Programs >
NET+OS Green Hills > HyperTerminal Connection,
and, depending on the port to which the
development board is connected, either COM1 or
COM2.

This task configures the IP address of the development
board.
During this procedure, be prepared to move quickly to the
HyperTerminal window at step 3, because you have only a
few seconds to respond to the prompt.

2

30
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Reboot the development board by disconnecting it from
the power source and reconnecting it.

This information is displayed in the HyperTerminal
window:

5

Enter the default root password, Netsilicon, and press
Enter.
The first of a series of configuration prompts
appears.

6

At each prompt, do one of these steps:

-

To accept the current value, press Enter.

-

To change a setting, enter a value and press Enter.

While scrolling through the settings, a prompt
indicates that you must press a key within five
seconds to change additional settings.

What’s next?
If using a Digi JTAG Link debugger, go on to the next section,
which installs the Digi JTAG Link debugger software.

3

Press any key within five seconds.

4

To change the configuration, press M, then press Enter.
A prompt for a root password is displayed.

If using a MAJIC debugger, follow the steps in “Appendix B:
Set up an IP address for MAJIC debugger” on page 49 and
“Appendix C: Configure the MAJIC debugger” on page 54.
If using the Raven debugger, skip to “Task 10: Build the BSP,
libraries, and applications” on page 36.

www.digi.com
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Task 8: Install the Digi JTAG Link debugger
license

1

Request an RDI license for your Digi JTAG Link debugger
by sending email to
"mailto:license_admin@digi.com"
license_admin@digi.com
including the serial number for the JTAG Link and the
JTAG Link RDI request key printed on the card
included in your NET+OS Green Hills Supplement
Pack. If you do not have an RDI request key, you can
purchase a license for the Digi JTAG Link from the
Digi online store or a Digi sales distributor (part
number DG-ACC-RDI-LIC).

2

32
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Select Start > All Programs > SEGGER > J-Link ARM > JLink RDI Config.

The J-Link RDI Configuration window opens:

3

Click License.
The J-Link RDI license management window opens

www.digi.com
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4

Click Add License.

What’s next?

The Add License dialog opens:

Go to the next task to configure the Digi JTAG Link debugger.

5

Enter the license associated with the serial number on
the back of the Digi JTAG Link debugger, then click OK.
The J-Link RDI license management window
reopens.

6

Click OK.

7

The J-Link RDI Configuration window reopens.

34
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Task 9: Configure the Digi JTAG Link debugger
This task selects configuration settings for the Digi JTAG Link
debugger.

1

Select Start > All Programs > SEGGER > J-Link ARM >
J-Link RDI Config.
The J-Link RDI Configuration dialog opens.

2

Click the CPU tab.

3

Under Endian, click Big endian.

4

Click OK.

What's next
You are ready to build the software. Go on to the next task,
which involves building the BSP, libraries, and sample
applications.

www.digi.com
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Task 10: Build the BSP, libraries, and
applications
This task builds the BSP, libraries, and sample applications,
including Hello World, one of the template applications
provided with NET+OS. This simple application writes Hello
World to the HyperTerminal window (which was opened in
Task 7, step 1).

36
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About building
One build file for each platform is used as the main access point
for building all the libraries, the BSP, and the applications
required for a NET+OS project.
When building a platform, always open the parent build file for
that platform. From this build file, several tasks are possible,
including:


Building the entire system.



Navigating to the application's build file, and building the
application.



Navigating to the BSP platform build file, and building
the BSP.

Build the entire system
This section uses the NS9360 as an example.

X To build the entire system:
1

The MULTI Project Builder window opens.

4

In the MULTI Project Builder window, select
Build > Rebuild ns9360_a.gpj.
The build begins, as shown here:

To open Green Hills MULTI v4.0.5, double-click the MULTI
icon on the desktop.

The MULTI Launcher opens:

2

Select File > Open Project Builder.

3

Browse to \netos, and select the platform.

When the build completes, the BSP, libraries, and all
the sample applications will be built.

www.digi.com
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Build an individual application

What's next

To rebuild an individual application, select the application
and select Build, as shown in this example.

Go on to the next task to run and debug the template
application.

1

Navigate to the template application for the ns9360_a
platform, as shown here:

2

Select Build > Rebuild image.
The build occurs and build messages are displayed.

38
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Task 11: Run and debug the template
application

Run the template application using the Digi JTAG
Link debugger
1

The application is run and debugged in the builder window. This
section describes how to debug the application using the Digi
JTAG Link debugger.

In the MULTI Project Builder window, select
Debug > Debug image.
This window is displayed:

If using the MAJIC debugger, go to “Appendix D: Run and
debug the template application with the MAJIC debugger” on
page 59. If using the Raven debugger go to “Appendix E: Run
and debug the template application with the Raven
debugger” on page 65.

2

Select Target > Show Connection Organizer.

www.digi.com
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The New Connection Method window opens:

The Connection Organizer window opens:

3

40

Select Method > New.

n n n
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4

In the Name edit box. enter Jlink.

5

From the Type pull-down menu, select
Multi-ICE (rdiserv), then click Create.

The Multi-ICE (rdiserv) Connection Editor opens:

6

Click the folder icon at the end of the line, navigate to
the netos/debugger_files folder, and select the setup
script (.mbs file) for the target hardware. For most
ARM9 platforms, use ns9xxx_jlink.mbs.

7

From the Processor pull down menu, select ARM7TDMI or
ARM9TDMI, depending on the processor in use.

8

Deselect Little Endian.

9

Click the Advanced tab.

www.digi.com
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This dialog opens:

10 Do these steps:
a Check Use RDI DLL.
b If the input text box next to the Use RDI DLL check
box contains text, delete it.
c Click Choose, navigate to the folder selected as the
destination for the JLink files, and select JLinkRDI.dll.
d In the Use RDI DLL check box, replace all back slashes
(\) with forward slashes (/).
e If using a sub-directory of the Program Files folder,
change Program Files to progra~1.
f Click Apply.
g Close the Multi-ICE (rdiserv) Connection Editor by
clicking OK, then close the Connection Organizer
window.
11 To start the application, in the MULTI Debugger window,
select Debug > Go.
If there is difficulty connecting, select
Target > Disconnect from Target, then go back to
step 10 and continue.

42
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12 When the application is loaded and starts running, the
application dialog appears in the HyperTerminal window.
Note that Hello World appears in the last line.

15 To continue execution, select Debug > Go.
16 Repeat steps 10 through 13 of this task.
When the breakpoint is reached, the screen looks
like this:

13 Select Debug > Halt.
14 At the MULTI> prompt at the bottom of the
MULTI Debugger window, set a breakpoint at the main
function by entering:
b main

Then press Enter.

You have now completed all the tasks in this exercise.

www.digi.com
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Tips and suggestions
Here are some tips for using NET+OS with Green Hills with
your own projects.

What should my next step be?

Where should I put my code, and why?



The bootloader (rom.bin), located in:
netos/src/bsp/platforms/your platform.



Your application (image.bin), located in
netos/src/examples/your example/32b.

Add your code as a subdirectory in the c:/netos/src/
examples directory. The software calls the applicationStart
function in the root.c file. Start by duplicating some other
example and modifying the Makefiles.
A good choice is naftpapp, the FTP server example. Add your
application to this example, which allows reloading new code
after it is running in flash. Without the FTP server in the
application, it is not possible re-flash the system.
To load specific settings, edit the root.c file. To configure
board settings, edit the appconf.h file.

44
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The next step is running your application from flash. The
flash code is broken up into two parts:

Appendix A: Update the MAJIC debugger’s firmware
This appendix describes how to update the firmware for the
MAJIC debugger using the MAJIC Setup Wizard.
Performing this procedure is required if you have a previous
version of the MAJIC firmware.
If an IP address of the MAJIC debugger is needed, see
“Appendix B: Set up an IP address for MAJIC debugger” on
page 49.

X To update the MAJIC debugger’s firmware:
1

Start the MAJIC Setup Wizard. Depending on your
Windows operating system, the menu sequence is:

-

Windows XP systems: Select Start > All Programs >
EPI Tools-EDTA > MAJIC Setup Wizard.

-

Windows 2000 systems: Select Start > Programs >
EPI Tools-EDTA > MAJIC Setup Wizard.

The EPI MAJIC Setup Wizard Introduction window opens:

www.digi.com
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2

Review the introduction and click NEXT.
The Choose Operation window opens:

3

From the Choose Update Type pull-down menu, select
Firmware update.
Then click Go.

46
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The MAJIC Firmware Update Installer dialog opens:

4

If the directory name is not already in the
Location of update files input box, browse to this
directory:
C:\ProgramFiles\EPITools\edta22A\ice\majic
and click NEXT.

The MAJIC Connection Parameters dialog opens:

5

Do these steps:

a Click I will be using an Ethernet IP address to
communicate with my MAJIC.
b Enter the IP address for the MAJIC.
c Make sure Use My Static IP address is selected.
Then click Update.

www.digi.com
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The Install Update dialog opens:

6

To begin the update, click OK.
A DOS window and the Check Your Installation
Result dialog open. Messages about the firmware
download are displayed in the DOS window:

48
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7

When the download finishes, do one of these steps:

-

If the download was successful, click OK in the
Check Your Installation Result dialog.

-

If the download was not successful, click Cancel in
the Check Your Installation Result dialog, and
repeat this procedure.

Appendix B: Set up an IP address for MAJIC debugger
This section describes how to set up an IP address for the MAJIC
debugger.

X To set up the IP address of the MAJIC debugger:
1

You must follow the instructions in this section if:

Using the serial cross cable that ships with the MAJIC,
connect the MAJIC to an available COM port on your PC.
If there is not an available connection on your PC,
reuse the one already connected to the development
board. In this case, close all applications associated
with the COM port, such as HyperTerminal.

You are a new user.
You are upgrading and do not know the IP address of your
MAJIC debugger.

2

Start the MAJIC Setup Wizard. Depending on your
Windows operating system, the menu sequence is:

-

Windows XP systems: Start > All Programs > EPI
Tools-EDTA > MAJIC Setup Wizard.

-

Windows 2000 systems: Start > Programs > EPI
Tools-EDTA > MAJIC Setup Wizard.

www.digi.com
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The EPI MAJIC Setup Wizard Introduction window
opens:

3

50

Click NEXT.
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The Choose Operation window opens:

4

From the Type of Connection pull-down menu, select
Static IP Address for Ethernet, then click Go.

The Configure MAJIC’s Ethernet Static IP Address
window opens:

The MAJIC Connection Parameters window opens:

6
5

Enter this network information:

-

IP Address

-

Subnet Mask

-

Default Gateway

then click NEXT.

Do these steps:

a Click I will be using a serial port to communicate with
my MAJIC.
b From the COM port to use pull-down menu, select the
serial port number.
c Make sure no other programs are using the COM port
selected.
d Click Install IP.
www.digi.com
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The Install Static IP dialog opens:

11 In the DOS window, ping the IP address by entering:
ping ip address

where ip address is the IP address of the MAJIC.

The DOS window looks like this:

7

Connect the MAJIC serial cable between the MAJIC
debugger’s serial port and the COM port selected in the
MAJIC Connection Parameters window (in step 6 of this
task), and then click OK.
A dialog and a DOS window open.

8

In the Check Your Installation Result dialog, confirm
that the IP address information in the DOS window is
correct by clicking OK.
If there is a problem, correct it and go back to step
1 of this task.

9

Connect an Ethernet cable from the MAJIC debugger to
the LAN hub or switch.

10 After the MAJIC debugger turns off, power-cycle the
MAJIC.
52
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Capturing output into setip.out
MON> fwo o setup ; do tv_ipx
//
eo
eo
eo
eo

NAME
tv_ip_gateway
tv_ip_address
tv_ip_netmask
: q y

= VALUE
= 10.52.32.135
= 10.52.32.1

DESCRIPTION
// Static IP address for target
// Static gateway IP address for

= 255.255.248.0

// Subnet mask for target

C:\Program Files \EPITools\edta21\bin>ping 10.52.32.135
Pinging 10.52.32.135 with 32 bytes of data:
Reply
Reply
Reply
Reply

from
from
from
from

10.52.32.135:
10.52.32.135:
10.52.32.135:
10.52.32.135:

bytes=32
bytes=32
bytes=32
bytes=32

time=1ms
time=1ms
time=1ms
time=1ms

TTL=254
TTL=254
TTL=254
TTL=254

Ping statistics for 10.52.32.135:
Packets: Sent = 4. Received = 4. Lost = 0 (0% loss).
Approximate round trip times in milli-seconds:
Minimum = 1ms. Maximum = 1ms. Average =
C:\Program Files\EPITools\edta21\bin>

(The colors of the text and background are reversed
in this screen for easier reading.)
If the ping succeeds, the IP address is installed.

If this response is not displayed:

-

Check the Ethernet connection to the MAJIC.

-

Confirm that the IP parameters are legal.

-

Verify that the MAJIC was power-cycled.

Otherwise, repeat this task.

12 Close the DOS window.
13 In the Check Your Install Results dialog, click OK.
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Appendix C: Configure the MAJIC debugger
This task configures software settings for the MAJIC debugger,
using the EPI MAJIC Setup Wizard.
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Configure the MAJIC debugger:
1

Start the MAJIC Setup Wizard. Depending on your
Windows operating system, the menu sequence is:

-

Windows XP systems: Start > All Programs >
EPI Tools-EDTA > MAJIC Setup Wizard.

-

Windows 2000 systems: Start > Programs >
EPI Tools-EDTA > MAJIC Setup Wizard.

The Choose Operation window opens:

The EPI MAJIC Setup Wizard Introduction window
opens:

2

Review the introduction and click NEXT.

3

From the Choose Your Debugger pull-down menu, select
RDI Compliant Debugger, and click Go.
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The Project Name window opens:

4

The CPU Configuration window opens:

Create a new project by entering a project name and a
brief description. Then click NEXT.

5

Do these steps:

a From the Select Your Processor Type pull-down
menu, select ARM926EJS.
b Under Select your Target’s Endianness, click
BigEndian. Under Startup Connection Mode, click
Instrusive Mode (reset and stop processor).
c Click NEXT.
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The MAJIC Connection Parameters window opens:

6

The Configuration Files window opens:

Do these steps:

a Click I will be using an Ethernet IP address to
communicate with my MAJIC.
b Enter the IP address for the MAJIC. Use the IP address
provided in Task 8, step 6.
c Make sure Use My Static IP address is selected.
d Click NEXT.

7

Click Use Existing Startup File, and do these steps:

a Click Browse.
b Navigate to Program Files > EPI Tools > edta22a >
Targets > ns9xxx directory.
c Select the file startice.cmd, and click Open.
d Click NEXT.
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The Perform Setup window displays a summary of the
selections:

The Destination Directory window opens:

8

Click Select a Destination Directory to Create/Copy
Startup Files to.
Browse to the directory to use for files that are
created or copied during the MAJIC setup.
Make sure that each name in the path is eight
characters or fewer and does not use any spaces.
Then click NEXT.
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9

Check Enabled for each item, then click
Perform Actions. This step creates MAJIC setup files in
the directory specified in step 8.
If the directory does not exist, the MAJIC Setup Wizard
displays a pop-up warning to create one. Click Yes to
create the directory.

10 To exit the wizard, click Done.

Appendix D: Run and debug the template application with the MAJIC debugger
This task shows how to run an application with MAJIC debugger.

X To run the template application using the MAJIC
debugger:

1

In the MULTI Project Builder window, select
Debug > Debug image.
This window is displayed:

2

Select Target > Show Connection Organizer.
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The Create New Connection Method dialog opens:

The Connection Organizer window opens:

4

Do these steps:

a In the Name input box, enter ns9xxx (for either the
ns9360_a or ns9750_a platform).
b From the Type pull-down menu, select ARMulator
(rdiserv) for ARM.
3

60

In the User Methods section of the window, right-click
as noted in the illustration, and select New.
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c Click Create.

The ARMulator (rdiserv) Connection Editor opens:

5

In the Connection portion of the Armulator window, do
these steps:

a From the Processor pull-down menu, select
ARM9TDMI. (This option is compatible with the
Net+Silicon ARM926EJS-based processors.)
b deselect Little Endian.
c Click the Advanced tab.
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This information is displayed in the center of the
window:

6

Do these steps:

a Select RDI DLL.
b If the input text box next to the RDI DLL check box
contains text, delete it.
c Click Choose, navigate to the folder selected as the
destination for the EPI files (in Task 9, step 8), and
select rdimajic.dll.
d In the Use RDI DLL text box, replace the back slashes
(\) with forward slashes (/).
e Click Apply.
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7

Close the ARMulator (rdiserv) Connection Editor by
clicking OK, then close the Connection Organizer
window.

8

If a HyperTerminal window is not open, open one as
instructed in Task 7, step 1.

9

In the MULTI Debugger window, select Target > Connect.

The Connection Chooser dialog opens:

When the program is loaded and starts to run, the sample
application dialog appears in the HyperTerminal window.
Note that Hello World appears in the last line of code.

10 Check that the target name matches the name entered
in step 4a, and click Connect.
11 In the MULTI Debugger window, select Debug > Go to
start running the program.
If there is any difficulty connecting, select
Target > Disconnect, then go back to step 7.

12 Select Debug > Halt.
13 At the MULTI> prompt at the bottom of the
MULTI Debugger window, set a breakpoint at the main
function by entering:
b main
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14 Select Target > Disconnect from Target, and repeat
steps 7 through 10.
When the breakpoint is reached, the screen looks
like this:

15 To continue execution, select Debug > Go.
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Appendix E: Run and debug the template application with the Raven debugger
1

In the MULTI Project Builder window, select
Debug > Debug image.
The window looks like this:

2

Select Target > Show Connection Organizer.
The Connection Organizer window opens:
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3

In the User Methods section of the window, right-click
and select New.
The Create New Connection Method dialog opens:

4

Do these steps:

a In the Name input box, enter a descriptive name for
the platform.
b From the Type pull-down menu, select Macraigor OCD
(ocdserv) for ARM.
Then click Create.
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The Macraigor OCD (ocdserv) Connection Editor
opens:

5

In the Macraigor OCD (ocdserv) Connection Editor, do
these steps:

7

In the MULTI Debugger, select Target > Connect.
The Connection Chooser dialog opens:

a In the input box next to Target Setup script, navigate
to the netos\debugger_files\ directory, and select the
script for the platform. The scripts have a .mbs
extension.
b In the Local section, click Raven. Then, from the
Parallel Port pull-down menu, select the parallel port
for the local connection.

6

c In the Processor section, from the Processor pulldown menu, select NetARM. From the Endian pulldown menu, select Big.

8

Check that the target name matches the name entered
in step 4a.

9

In the Connection Chooser dialog, click Connect.

Click Apply.

10 In the MULTI Debugger window, select Debug > Go to
start running the program.

Click OK to close the Macraigor OCD (ocdserv)
Connection Editor, then close the Connection Organizer
window.

If there is difficulty connecting, select
Target > Disconnect, then go back to step 7.
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When the program is loaded and starts running, the
sample application dialog appears in the HyperTerminal
window, as shown here. Note that Hello World appears
in the last line of the window.

12 Select Target > Disconnect from Target, and repeat
steps 7 through 10. When the breakpoint is reached, the
screen looks like this:

11 Select Debug > Halt.
At the MULTI> prompt at the bottom of the MULTI
Debugger window, set a breakpoint at the main function
by entering:
b main
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13 To continue execution, select Debug > Go.
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