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Chapter 1: Introduction

Throughout this guide you will:

1. Configure the various interfaces of the ConnectPort X5 R via the device’s Web Interface.

2. Create an iDigi® Device Cloud™ account and add your ConnectPort X5 R to your iDigi device 
inventory.

3. Download and install the Digi ESP™ for Python Integrated Development Environment (IDE), 
which will allow you to run your first Python sample program on your ConnectPort X5 R. 

4. Verify the connection between your ConnectPort X5 R and the iDigi Device Cloud via the device’s 
cellular interface.

5. Use the Digi ESP for Python IDE to build, download, and run your first Python sample project on 
your ConnectPort X5 R. This sample program will upload the GPS position information of the 
ConnectPort X5 R to the iDigi Device Cloud.

6. View the uploaded GPS data from the ConnectPort X5 R using iDigi Manager Pro™.
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ConnectPort X5 R CDMA Product Features

1. Wiring harness connector

2. WiFi antenna connector

3. Cellular antenna connector

4. GPS antenna connector

5. XBee antenna connector 

6. Mounting holes

7. LED status indicators

WIFI         CELLULAR              
      GPS              

    XBEE

2
3

4 5
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Side View

7

Top View
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ConnectPort X5 R GPRS Product Features

1. Wiring harness connector

2. WiFi antenna connector

3. Cellular antenna connector

4. GPS antenna connector

5. XBee antenna connector

6. SIM Card Cover (if removed, SIM slot is revealed) 

7. Mounting holes

8. LED status indicators

Side View
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       GPS             
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ConnectPort X5 R Iridium Product Features

1. Wiring harness connector

2. WiFi antenna connector

3. Cellular antenna connector

4. GPS antenna connector

5. SAT (satellite) antenna connector 

6. SIM Card Cover (if removed, SIM slot is revealed)

7. Mounting holes

8. LED status indicators

Side View

WIFI         CELLULAR              
      GPS              

       SAT  

2
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1
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LEDs

1. Power LED

2. Status LED

3. Cellular Link/ACT LED

4. Cellular Signal Strength LED

5. GPS LED

6. XBEE LED (ConnectPort X5 R CDMA and GPRS gateways)
SAT LED (ConnectPort X5 R Iridium gateways)

7. Ethernet LED

8. WiFi LED

1
2
3

4

5
6
7
8
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The following table displays LED functionality for the ConnectPort X5 R Family of gateways.

LED Color and 
Light Pattern

Description

POWER Off Device is off

Solid blue Device is on

STATUS Solid amber Hardware is initializing

1-1-1 blinking 
amber

Firmware is initializing

1-5-1 blinking 
amber

Device configuration has been restored to its factory 
defaults

Off Device is powered on and ready for operation

CELLULAR 
LINK

Solid green Connected to the cellular network

CELLULAR 
ACTIVITY

Blinking green Cellular traffic/activity

CELLULAR 
SIGNAL 
STRENGTH

Solid green Relative signal strength indicator (RSSI), shown as a 
number of LEDs
          - 1 LED: Weak cellular signal
          - 2 LEDs: Good cellular signal
          - 3 LEDs: Strong cellular signal

GPS Off No GPS satellites in range

Blinking green GPS satellites detected, acquiring lock

Note: If the antenna is not connected to the ConnectPort X5 R 
device, the GPS device can indicate “phantom” satellites. This 
will cause the device to behave as if many satellites are visible 
to it, though it will never establish a satellite lock. This behavior 
is visible as continuous, fast blinking.

Solid green A GPS satellite lock has been acquired 

SAT
(ConnectPort X5 R 
Iridium only)

Solid green Iridium Satellite link is up

Blinking green Iridium Satellite traffic/activity

XBEE
(ConnectPort X5 R 
GPRS and CDMA 
only)

Solid green XBee link is up

Blinking green XBee traffic/activity

ETHERNET Solid green Ethernet link is up

Blinking green Ethernet traffic/activity

WIFI Solid green WiFi link is up

Blinking green WiFi traffic/activity
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Digi Information

Contact Information
For more information about your Digi products, or for customer service and technical support, contact 
Digi International. 

To contact Digi International by Use

Mail

Digi International

World Headquarters

11001 Bren Road East

Minnetonka, MN 55343

Phone 
1-877-434-4439 or

1-952-912-3456

Web www.digi.com/support

www.digi.com/support
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Chapter 2: Ethernet & Cellular Configuration

By default, the Ethernet interface of the ConnectPort X5 R is configured as a DHCP Server with a static IP 
Address of 192.168.1.1. 

Connecting to the Web Interface Home Page
1. Connect one end of the provided Ethernet cable to your PC, and the other end to the 

ConnectPort X5 R Ethernet port (ensure that your PC is configured to obtain its IP address via 
DHCP).

2. Open the Web Interface of the ConnectPort X5 R by navigating to the 192.168.1.1 address in a web 
browser on the PC. You will see a screen similar to the following (this is the device’s Home page): 

NOTE: ConnectPort X5 R Iridium units will not have an XBee Network link displayed 
within their Web Interface Home page because these units do not support XBee.
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Configuring Ethernet Settings 
To configure your device’s Ethernet settings open the Ethernet Network Configuration page by clicking on 
Configuration > Network from the left-hand menu.

Within the Network Configuration page various Ethernet parameters can be configured depending on your 
type of installation. Basic settings can be configured in the Ethernet IP Settings page.
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Configuring the Ethernet Interface
To configure your device’s Ethernet interface settings perform the following steps: 

1. Click on Configuration > Network from the left-hand menu. You should see the Network 
Configuration screen (with the Ethernet IP Settings page displayed by default) as shown:

2. Click the DHCP Server Settings link and open the DHCP Server Settings page.
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3. To disable the DHCP Server, un-check the "Enable Dynamic Host Configuration Protocol (DHCP) 
Server" entry. Click Apply when finished.
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4. Return to the Ethernet IP Settings page by clicking the Ethernet IP Settings link.

5. Configure the ConnectPort X5 R with either a static IP address, or have it get its IP address from a 
DHCP Server, whichever method is appropriate. Click Apply when finished.

6. Disconnect the ConnectPort X5 R from your PC and then connect it to the Ethernet network (if the 
PC needs to be reconfigured with a static IP address, do this prior to moving the PC to the Ethernet 
network as well).
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Configuring the Cellular Interface
Configuring the ConnectPort X5 R cellular interfaces will vary depending on whether the 
ConnectPort X5 R supports the GSM/Edge or CDMA cellular network.  

This section provides examples of how to configure the ConnectPort X5 R cellular interface for three of 
the popular cellular networks: AT&T, Verizon and Sprint. 

After following the example for your specific cellular provider (for Verizon users see page 18 and for 
Sprint users see page 21), go to the “Verifying the Cellular Connection Status” section on page 24.

GSM/Edge Cellular Configuration Example (AT&T)
To configure a GSM/Edge ConnectPort X5 R cellular interface perform the following steps:

1. Click on Configuration > Mobile from the left-hand menu. 

2. Configure the Mobile Service Provider Settings by selecting the Service Provider and Service Plan/
APN, and entering the Customer Plan Name appropriate for your environment as shown.

3. Click Apply when finished.

Your mobile configuration is complete. Proceed to the “Verifying the Cellular Connection Status” section 
on page 24.
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CDMA Cellular Configuration Example (Verizon)

NOTE: This example assumes that the ESN/MEID# for the ConnectPort X5 R has been 
activated with your cellular provider. You can find the ESN/MEID# on the side of your unit.

To configure a CDMA ConnectPort X5 R cellular interface perform the following steps:

1. Click on Configuration > Mobile from the left-hand menu and select Verizon Wireless from the 
Service Provider drop-down menu. You should see a screen similar to the following:
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2. After selecting a Service Provider, the unit needs to go through its provisioning process. Click the 
Provision Device button, and then follow the steps displayed within the Mobile Device 
Provisioning dialog screens.

NOTE: The default options within the Mobile Device Provisioning dialog screens will be 
correct for most installations. 

3. When the following screen is displayed, select the Automatically provision the mobile device 
option.
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4. Continue to go through the mobile provisioning process until you see the following screen. This 
screen will indicate that the mobile provisioning process completed successfully.

5. Click Finish to return to the Mobile Configuration page. 

6. Click Apply on the Mobile Configuration page when finished.

Your Mobile configuration is complete. Proceed to the “Verifying the Cellular Connection Status” section 
on page 24.
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CDMA Cellular Configuration Example (Sprint)

NOTE: This example assumes that the ESN/MEID# for the ConnectPort X5 R has been 
activated with your cellular provider. You can find the ESN/MEID# on the side of your unit.

To configure a CDMA ConnectPort X5 R cellular interface perform the following steps:

1. Click on Configuration > Mobile from the left-hand menu and select Sprint PCS from the Service 
Provider drop-down menu. You should see a screen similar to the following: 

2. After selecting a Service Provider, the unit needs to go through its provisioning process. Click the 
Provision Device button, and then follow the steps displayed within the Mobile Device 
Provisioning dialog screens.

NOTE: The default options within the Mobile Device Provisioning dialog screens will be 
correct for most installations. 
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3. When the following screen is displayed, select the Automatically provision the mobile device 
option. 
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4. Continue to go through the mobile provisioning process until you see the following screen. This 
screen will indicate that the mobile provisioning process completed successfully.

5. Click Finish to return to the Mobile Configuration page. 

6. Click Apply on the Mobile Configuration page when finished.

Your Mobile configuration is complete. Proceed to the “Verifying the Cellular Connection Status” section 
on the next page.
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Verifying the Cellular Connection Status
Once the correct cellular configuration has been applied, the ConnectPort X5 R will begin to establish its 
cellular connection. You can verify the connection status by navigating to the Administration > System 
Information > Mobile page.

NOTE: In the above example, the ConnectPort X5 R is connected to the cellular network and 
has obtained the 166.130.120.49 address for its cellular interface.


You have completed Ethernet and Cellular configuration of your ConnectPort X5 R. 
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Chapter 3: WiFi Configuration

Configuring the WiFi Interface
To configure the ConnectPort X5 R WiFi interface perform the following steps:

1. Click on Configuration > Network from the left-hand menu. You should see the Network 
Configuration screen (with the Ethernet IP Settings page displayed by default) as shown:

Within the Network Configuration page WiFi IP, LAN, and Security settings can be configured depending 
on your type of installation.
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WiFi IP Settings Page
2. Open this page by clicking on the WiFi IP Settings link (Configuration > Network > WiFi IP 

Settings).

The WiFi IP Settings page allows you to set your ConnectPort X5 R to obtain an IP address on the WiFi 
network automatically (using DHCP) or enter in your own IP address.

3. Configure your WiFi IP settings as desired. Click Apply when finished.    
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WiFi LAN Settings Page
4. Open this page by clicking on the WiFi LAN Settings link (Configuration > Network > WiFi 

LAN Settings).

The WiFi LAN Settings page allows you to set your connection type and name your network. The above 
example configures the ConnectPort X5 R to connect to the "TRENDnet"  WiFi network, using Channel 1.

5. Configure your WiFi LAN settings as desired. Click Apply when finished. 
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WiFi Security Settings Page
6. Open this page by clicking on the WiFi Security Settings link (Configuration > Network > WiFi 

Security Settings).

The WiFi Security Settings page allows you to set Network Authentication, Data Encryption, WEP Key, 
WPA PSK, and Username/Password information for your network. The above example configures the 
ConnectPort X5 R to use WPA-PSK authentication using TKIP encryption with a WPA PSK passphrase.

7. Configure your WiFi security settings as desired. Click Apply when finished.
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DHCP Server Settings Page
8. If the ConnectPort X5 R is to act as a DHCP Server on the WiFi network, open this page by clicking 

on the DHCP Server Settings link (Configuration > Network > DHCP Server Settings).

9. The ConnectPort X5 R can act as a DHCP Server on either its WiFi or Ethernet interface. To enable 
the DHCP Server on the WiFi network, check the "Enable Dynamic Host Configuration Protocol 
(DHCP) Server" entry and select the "wln0" Scope name. Configure the other parameters as 
appropriate. Click Apply when finished. 
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Verifying the WiFi Connection Status
You can verify the WiFi connection status by navigating to the Administration > System Information > 
Mobile page. You should see a screen similar to the following displaying the settings and statistics for the 
WiFi network.


You have completed WiFi configuration of your ConnectPort X5 R. 
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Chapter 4: Configuring the Gateway Priority

With all the interfaces configured, the ConnectPort X5 R could conceivably reach the Internet via multiple 
interfaces (Ethernet, Cellular, or WiFi). Configuring the ConnectPort X5 Gateway Priority List determines 
the priority for each of its network interfaces. By default the ConnectPort X5 R gives the Mobile (Cellular) 
interface the highest priority. 

The ConnectPort X5 R IP Gateway Priority List and the DNS Priority List are configurable via the 
Configuration > Network > Advanced Network Settings page as displayed below.:

If you wish to change the DNS Server or IP Gateway Priority order, click on the desired entry and use the 
arrow keys to raise, or lowers its priority in the list of entries. Click Apply when finished.


You have configured the IP Gateway Priority of your ConnectPort X5 R. 
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Chapter 5: Viewing Status Information

Viewing IP Address Information
The ConnectPort X5 R Home page will display the IP address for the Ethernet, Cellular and WiFi 
networks.

Viewing Ethernet Statistics
To view information about the Ethernet Link as well as Ethernet and IP statistics, navigate to the 
Administration > System Information > Network page.

Verifying the GPS Connection Status
You can check the GPS connection status by navigating to the Administration > System Information > 
Position page. 


You have verified the GPS connection status of your ConnectPort X5 R. 
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Chapter 6: iDigi

What is iDigi?
The iDigi Device Cloud is the embedded industry’s first ready-to-use cloud computing platform for device 
networking and management. It provides secure application messaging, data storage and device 
management for networks comprised of wired, cellular and satellite-connected devices.

What is Cloud Computing?
Cloud computing offers a flexible new approach to delivering IT services. In the most basic sense, “The 
Cloud” is resources (hardware, software, infrastructure and device networks) that can be accessed through 
the Internet. The benefits of cloud computing are similar to a public utility model: only buy what you need, 
when you need it, with the ability to quickly scale resources on-demand as resource utilization grows.

What is a Device Network?
Sometimes referred to as Machine-to-Machine (M2M), device networks enable both wired and wireless 
systems to communicate with other devices and applications. A device (such as a sensor or meter) captures 
an event (such as temperature, tank level, etc) which is relayed through a network aggregation layer 
(wired, wireless or both) and infrastructure to an application (software program) that translates the 
captured event into meaningful information (for example, tanks need to be emptied or refilled).

What is iDigi Manager Pro?
iDigi Manager Pro is the Software as a Service (SaaS) component of the iDigi Device Cloud. It is a web-
based graphical user interface for management and control of remote devices. iDigi Manager Pro will be 
discussed in more detail on page 35.

For more information about iDigi visit the iDigi web site at www.idigi.com, or see the iDigi User’s Guide.

www.idigi.com
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Create an iDigi Device Cloud Account
The features provided by iDigi are made available by signing up for a free iDigi Device Cloud account. 
The iDigi Device Cloud account is a full production environment, designed and tested to provide a robust 
solution for large-scale device network deployments. Offering commercial-grade availability, on-demand 
scaling, active monitoring and a best-of-breed security policy, the iDigi Device Cloud supports dynamic 
device networks with role-based access control and a host of management tools. When you create your 
free iDigi Device Cloud account, you have access to iDigi Manager Pro with a limit of 5 iDigi-registered 
devices, 30 iDigi SMS Messages per month (billing period), and unlimited iDigi Web Services. When you 
are ready to expand your device network and add your 6th device, you will be prompted to upgrade your 
iDigi account.

To create your free iDigi Device Cloud account on the US cloud navigate to https://www.idigi.com and 
click SIGN UP NOW FOR FREE, then follow the steps for creating your account. 

If you need help creating an account, follow the steps outlined in the iDigi Account Creation Guide 
available online at: http://ftp1.digi.com/support/documentation/html/90002178/

NOTE: If you already have an iDigi user account, login with your user 
credentials and skip ahead to the “Add your ConnectPort X5 R to your iDigi 
Inventory” section on page 35.

https://www.idigi.com
https://www.idigi.com/
http://ftp1.digi.com/support/documentation/html/90002178/
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Add your ConnectPort X5 R to your iDigi Inventory
iDigi Manager Pro is a web based device management application that allows a user to manage their 
inventory of iDigi devices. iDigi Manager Pro delivers capabilities that empower IT, network operations 
and customer support organizations to conquer the challenges of managing the vast array of equipment in 
their device networks.

To add your ConnectPort X5 R to your iDigi device inventory, perform the following steps:

1. Open the Devices page by clicking the Devices menu from within the iDigi Manager Pro tab.

2. Click the Add Devices  button in the toolbar to open the Add Devices applet. 

3. The Add Devices applet (shown below) is used to discover the iDigi devices on your network. Since 
the ConnectPort X5 R is connected via a USB cable, it needs to be added to your iDigi device 
inventory manually. Click the Add Manually button to begin adding your device manually. 
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4. Using the drop-down menu select the IMEI # option then enter the Modem Serial Number 
(IMEI or MEID) of the device (which can be found on the label on the bottom of the device) into the 
field. 

5. Once the IMEI number has been entered click Add. Your device will appear within the window. 
Click OK to exit the Add Devices applet. 

6. Ensure that your device is displayed in the devices list on the Devices Page. Notice that the device is 
‘Disconnected’ (as indicated by the red ‘Disconnected’ icon). Later in this guide you will configure 
the ConnectPort X5 R to properly establish both a cellular and iDigi connection which will change 
the device’s state to ‘Connected’ (as indicated by a green ‘Connected’ icon).
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Chapter 7: Digi ESP for Python

Digi ESP for Python Overview
Built on the open Eclipse framework, Digi ESP for Python provides an easy-to-use and professional 
Python development environment with graphical user interface. 

Digi ESP for Python offers a wide variety of state-of-the-art development tool features that make 
embedded development easier and faster than ever before. These include intelligent editor coding aids 
(syntax highlighting, auto-indent/bracket-matching, code completion assistance), on-the-fly template 
insertion, and simple single-click initiation of project build processes and debug sessions. This 
development environment also includes extensive documentation, tutorials, and code samples to help you 
get started developing custom applications for your product. 

For example, applications can be created to: 

• Aggregate data on the ConnectPort X5 R throughout the day, then upload to iDigi once a day.

• Develop a driver for a custom protocol to talk to a device connected to the ConnectPort X5 R.

• Translate data, for example, from raw serial into an XML format that can be consumed by other 
systems, such as iDigi.
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Download and Install Digi ESP for Python
1. Navigate to http://www.digi.com/connectportx5 and click on the Download Digi ESP for Python 

link.

2. A new page will be displayed, within this page click the Download Digi ESP for Python button. 

3. The various download options for the Digi ESP for Python framework will be displayed. Based on 
your operating system, click the link to download Digi ESP for Python.

4. Once the Digi ESP for Python framework has been downloaded, run the Digi ESP for Python 
framework installation wizard. Follow the steps in the wizard until the Choose Components dialog 
is displayed.

http://www.digi.com/connectportx5


© 2013 Digi International, Inc.    39

ConnectPort  X5  R  Family  Getting  Started  Guide  

5. When the Choose Components dialog is displayed, select the ConnectPort X5 Family installation 
from the drop-down menu.

6. Follow the installation until arriving at the Completing the Digi ESP for Python Setup Wizard 
dialog. Uncheck both options, then click Finish.
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Using Digi ESP for Python
The Digi ESP for Python IDE provides sample Python programs that can easily be downloaded to your 
ConnectPort X5 R. This section will guide you through the steps required to run your first sample project.

1. If it is not already open, launch Digi ESP for Python (Start > Digi > iDigi > Digi ESP for Python).  

2. The first time you open Digi ESP for Python you will be prompted to select a workspace directory. 
Use the default workspace directory (or click the Browse button and navigate to your desired 
alternate workspace location), check the "Use this as the default and do not ask again" box, and click 
OK.

NOTE: Note: The Digi ESP for Python framework 'workspace' is the directory 
where projects and configurations will be stored. The default location for this 
directory is a sub-folder called workspace on the user home directory, for 
example, C:/Documents and Settings/[username]/workspace.
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3. If you are using Digi ESP for Python 2.0 or newer, the first time you run Digi ESP for Python the 
Workbench is displayed. 

NOTE: Before the Workbench is displayed, the Welcome page is displayed for 
just a moment and is then displayed along the right side of the Workbench 
screen. Throughout this getting started experience the Welcome page will be 
minimized. When minimized the Restore button appears in the lower-left corner 

of the screen . If needed, click this button in order to maximize the 

Welcome screen, or select Help > Welcome from the main menu. 

 


If you are using an earlier version of Digi ESP for Python, the first time you run Digi ESP for Python 
the Welcome screen is displayed. To open the Workbench from the Welcome page, click the 
Workbench icon.
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4. You will need to run the Digi ESP for Python Package Manager. Package Manager allows Digi 
ESP for Python to check the Package Manager Update Server for updates and enhancements. These 
updates will keep your Digi ESP for Python environment current. To open Package Manager, 
navigate to Package Manager > Open Package Manager from the Workbench page’s main menu. 

5. If Package Manager discovers any available updates, a dialog box similar to the one below will be 
displayed. If updates are available for your product, they should be installed. The dialog below is an 
example of what you would see if packages were available for a new product like the ConnectPort 
X5 R Iridium model. Locate your ConnectPort X5 R package in the list and click to select it. Once 
selected, click the Request Install button. Repeat as needed for any additional packages.

NOTE: If no packages need to be installed, skip this step and proceed with
Step 8 on page 44.

6. All requested installs will be displayed within the Package Request List Panel, click the Continue 
button to proceed with the installation of your package(s). 
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7. Verify that all packages to be installed are displayed in the installation panel, then click the Proceed 
button. Once all packages are installed a dialog box will appear, click OK. 

Once all packages have been successfully installed, Digi ESP for Python may need to restart. If new 
packages were installed and Digi ESP for Python was restarted, make sure that the Workbench is 
displayed (as described in Step 3 on page 41).

NOTE: If at any point you close Digi ESP for Python, it can be reopened by 
double-clicking on the Digi ESP for Python icon from your computer’s desktop, 
or by navigating to Start > Digi > iDigi > Digi ESP for Python.
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8. From the Workbench’s main menu select File > New > Digi Python Application Sample Project 
to open the Digi Python Application Sample Project Wizard. The Sample Selection wizard page will 
be displayed (as shown below).
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9. Click to enable the ‘Show only samples compatible with platform:’ checkbox, then select your 
ConnectPort X5 R gateway from the drop-down menu. For the example used in this Chapter, the 
ConnectPort X5 R ZB Wifi CDMA gateway is selected. 

10. Locate the iDigi GPS Sample within the sample projects list, then click its checkbox to enable the 
sample project. Click Next when finished.
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11. Within the Remote Device Selection wizard page, ensure that Use Current Remote Device is 
selected and then click the New… button to create a new remote configuration.
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12. After clicking the New… button, the Device Manager wizard dialog will open. Initially, there are 
no Remote Configurations listed in the Device Manager. Click the Device Discovery button 
(highlighted below) to begin the process of creating a new configuration. 

NOTE: The left side of the dialog lists the Remote Configurations that exist in 
the Workbench. 
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13. A dialog will ask you to identify a location where the Digi ESP for Python framework should look 
for devices. Select Local Are Network  and click OK when finished. 
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14. A progress dialog is displayed, indicating that the Digi Device Discovery utility is searching for 
devices. When the search is finished the Digi Device Discovery dialog is displayed listing all the 
Digi devices discovered on your local network. 

NOTE: The image below is for reference purposes. You will have fewer 
(possibly only one) device(s) in your device list.

15. Click on your device to select it from the list, and then click the Create Configuration button.
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16. Ensure that your ConnectPort X5 R gateway is displayed in the ‘Select the connected device type 
from the list:’ drop-down menu. For the example used in this guide, the ConnectPort X5 R ZB 
Wifi CDMA gateway should be displayed. 

NOTE: The name of your ConnectPort X5 R gateway should be automatically 
populated in this drop-down list. Only change the ‘Select the connected device 
type from the list:’ value if your specific ConnectPort X5 R gateway is not 
displayed. 

17. Click the Set Current button to make this configuration the current one, which means that the 
Digi ESP for Python framework will use it to perform several operations that require interaction 
with the remote device (reboot, transfer files, etc.).
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18. After clicking the Set Current button you will be redirected back to the Digi Python Application 
Sample Project Wizard. Make sure that Use Current Remote Device is selected, and click Next.
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19. When the Remote Device’s Information wizard page is displayed, click Next.
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20. When the Review wizard page is displayed, click Finish.
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Once the wizard closes your selected project, idigi_gps, will be displayed in your Digi ESP for Python 
workbench’s workspace. 

21. You are now ready to run your sample project. Using the Run As button’s drop-down menu 
(shown below) go to Run As > Remote Digi Python Application. 
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The Source View region of the Workbench screen (highlighted below) will display status messages as the 
project builds, downloads files to your ConnectPort X5 R, reboots your ConnectPort X5 R (in order to start 
the application), and finally starts sending GPS application data to your ConnectPort X5 R. 

A total of 10 GPS data messages will be sent, one every 5 minutes for a total of 50 minutes. You will view 
this GPS data in the next chapter of this document.

For ConnectPort X5 R Iridium users, see “Appendix A: Iridium (Satellite) Setup and Sample Program” on 
page 58 for an Iridium specific example using Digi ESP for Python.
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Each of the 10 data messages sent from your ConnectPort X5 R to the iDigi Device Cloud can be viewed 
in their entirety using iDigi. This section will guide you through the steps required to view your uploaded 
GPS data.

1. Login to your iDigi Device Cloud account.

2. Open the Files page by clicking the Data Services tab.

NOTE: The Data Services page contains menus for the Files page and the Data 
Streams page. The Files page is displayed by default after selecting the Data 
Services tab. 

A data folder containing your GPS data will be displayed. The name of the folder is the full iDigi Device 
ID of your ConnectPort X5 R. 

3. Double-click on the data file to open it, then double-click on the device_gps data file to open its 
individual data messages. 
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4. 10 data entries are displayed, indicating that your sample program ran for an entire 50 minute 
session.

5. Double-click on one of the files to display its contents; for example the GPS positioning information 
from the ConnectPort X5 R.

This is the end of the Digi ESP for Python Application Sample Project demonstration. You can rerun the 
sample program at any time by repeating Step 16 of Chapter 8, and its subsequent steps. To stop a running 
Python Program, simply click the              Reboot Target button. 
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Appendix A.  Iridium (Satellite) Setup and 
Sample Program

NOTE: The information within this Appendix is for ConnectPort X5 R Iridium 
users only.

Creating an Iridium User Account
Prior to using the ConnectPort X5 R Iridium’s satellite network interface you must first create a user 
account with Iridium. To do so send an email to Satellite.Setup@digi.com with the following information:

• Your name, contact information, and whether you are a new user.

• The product model name you are using (“ConnectPort X5 R WiFi GPRS Iridium” in this case).

• The IMEI (SAT): number of your ConnectPort X5 R Iridium. This number can be found on the 
product label on the side of your gateway (as shown).

Once your account is activated proceed with the next section of this Appendix.

A

Ethernet MAC:

CoO: USA

123456789012345

1132

0004F3456DEFConnectPort X5 R
IMSI:
ICC ID:NONE

Wi-Fi MAC:

PN:

95015577

SN:

Contains:
FCC ID: Q639602

IC: 4629A-9602

123456789012345

0004F3123ABC

IMEI (Sat):

NONE

This device complies with Part 15 of the FCC Rules.  Operation
is subject to the following conditions:  1) this device may not
cause harmful interference, and  2) this device must accept
any interference received including interference that may
cause undesired operation.

50001676-31 A
WiFi GPRS Iridium

IMEI (Cell):00043F123ABC
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Verifying the Iridium User Account
To verify that your Iridium user account was configured correctly:

1. Navigate to https://spnet3.iridium.com/ and login using your Iridium user credentials. 

The Iridium Home Page will be displayed. 
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2. Enter your ConnectPort X5 R Iridium IMEI (SAT) number (see the image on page 58 for location) 
of your device into the Search field, then click the Search button.

3. Your Iridium contract information will be displayed. Click on the Contract ID number 
(SUB-XXXXXXXXXX).
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This will display detailed information about your contract. Verify that the information you 
configured in the“Creating an Iridium User Account” section is correct. Your IMEI (SAT)
number should be displayed, and the Delivery Details section should have the following items 
configured:
Method = Email
Destination = the email address you provided when you created your Iridium user account
Ring Alerts = checked
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Digi ESP for Python - Iridium Sample Program
The Digi ESP for Python IDE provides a Python Iridium sample program that can easily be downloaded to 
your ConnectPort X5 R Iridium. This section will guide you through the steps required to run this sample 
project.

1. If it is not already open, launch Digi ESP for Python (Start > Digi > iDigi > Digi ESP for Python).

2. If you are using Digi ESP for Python 2.0 or newer, the first time you run Digi ESP for Python the 
Workbench is displayed. 

NOTE: Before the Workbench is displayed, the Welcome page is displayed for 
just a moment and is then displayed along the right side of the Workbench 
screen. Throughout this getting started experience the Welcome page will be 
minimized. When minimized the Restore button appears in the lower-left corner 

of the screen . If needed, click this button in order to maximize the 

Welcome screen, or select Help > Welcome from the main menu. 

 

If you are using an earlier version of Digi ESP for Python, the first time you run Digi ESP for Python 
the Welcome screen is displayed. To open the Workbench from the Welcome page, click the 
Workbench icon (shown on the next page).
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3. From the Workbench’s main menu select File > New > Digi Python Application Sample Project 
to open the Digi Python Application Sample Project Wizard. The Sample Selection wizard page will 
be displayed (as shown below).



© 2013 Digi International, Inc.    64

ConnectPort  X5  R  Family  Getting  Started  Guide  

4. Click to enable the ‘Show only samples compatible with platform:’ checkbox, then select 
ConnectPort X5 R Wifi GPRS Iridium from the drop-down menu. 

5. Locate the Iridium sample within the sample projects list, then click its checkbox to enable the 
sample project. Click Next when finished.
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6. Within the Remote Device Selection wizard page, ensure that Use Current Remote Device is 
selected and then click the New… button to create a new remote configuration.
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7. After clicking the New… button, the Device Manager wizard dialog will open. Initially, there are no 
Remote Configurations listed in the Device Manager. Click the Device Discovery button 
(highlighted below) to begin the process of creating a new configuration. 

NOTE: The left side of the dialog lists the Remote Configurations that exist in 
the Workbench. 
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8. A dialog will ask you to identify a location where the Digi ESP for Python framework should look 
for devices. Select Local Are Network  and click OK when finished.  
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9. A progress dialog is displayed, indicating that the Digi Device Discovery utility is searching for 
devices. When the search is finished the Digi Device Discovery dialog is displayed listing all the 
Digi devices discovered on your local network. 

NOTE: The image below is for reference purposes. You will have fewer 
(possibly only one) device(s) in your device list.

10. Click on your device to select it from the list, and then click the Create Configuration button.
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11. Ensure that ConnectPort X5 R Wifi GPRS Iridium is displayed in the ‘Select the connected 
device type from the list:’ drop-down menu. 

NOTE: The name of your ConnectPort X5 R gateway should be automatically 
populated in this drop-down list. Only change the ‘Select the connected device 
type from the list:’ value if your specific ConnectPort X5 R gateway is not 
displayed. 

12. Click the Set Current button to make this configuration the current one, which means that the 
Digi ESP for Python framework will use it to perform several operations that require interaction 
with the remote device (reboot, transfer files, etc.).



© 2013 Digi International, Inc.    70

ConnectPort  X5  R  Family  Getting  Started  Guide  

13. After clicking the Set Current button you will be redirected back to the Digi Python Application 
Sample Project Wizard. Click the Select Specific Remote Device radio button then select your 
device from the list (if applicable) to ensure that your ConnectPort X5 R Iridium is selected. Click 
Next to proceed.
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14. When the Remote Device’s Information wizard page is displayed, click Next.
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15. When the Review wizard page is displayed, click Finish.
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Once the wizard closes your selected project, iridium_sample, will be displayed in your Digi ESP for 
Python workbench’s workspace. 

16. You are now ready to run your sample project. Using the Run As button’s drop-down menu 
(shown below) go to Run As > Remote Digi Python Application. 
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The Sample Console region of the Workbench screen (highlighted below) will display status messages as 
the sample project builds and is launched on your device.

This sample program will turn on the Iridium satellite modem, and wait for the modem to obtain a good 
satellite signal. Once a this signal is obtained, it will send out a "Hello World!" message to the Iridium 
network. This message will ultimately arrive as an email in your inbox.

After sending this message, the sample program will display Receive and Transmit counters waiting for 
you to send it a message. In order to send this message you will need to return to the Iridium website.
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17. Navigate to https://spnet3.iridium.com/ and login using your Iridium user credentials (see page 59 
for login page image). 

18. Navigate to the Tools > SBD Messenger page. Enter your ConnectPort X5 R Iridium IMEI (SAT) 
number into the IMEI field and the word “Hello” into the SBD Message field, then click the Send 
button.

19. After clicking the Send button you should see a screen similar to the following:
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20. Return to Digi ESP for Python and observe the activity within the iridium_sample_Console 
window (highlighted below). It may take about a minute for a messages to arrive on the ConnectPort 
X5 R Iridium, so please be patient. 

Once a message has been received the RxCnt (received message count) will increment and the 
ConnectPort X5 R Iridium will try to echo this message and the unit's GPS coordinates back to you. If the 
ConnectPort X5 R Iridium is unable to successfully send this message upstream to the Iridium network, 
you will see an error message in the Console window and the TxCnt (transmit message count) will not 
increment. 

Repeat Steps 18 and 19 (on the previous page) to send another message to the ConnectPort X5 R. 

If the ConnectPort X5 R Iridium is successful in sending this message you will l receive an email with an 
attachment named something similar to the following: 300234010154270_000001.sbd (IMEI (SAT) 
number of the device_message number.sbd), that contains data similar to the following: Hello 
(33.743766784667969, -118.02503204345703, 6.4000000953674316, 1334.0).

This is the end of the Digi ESP for Python Application Iridium Sample Project demonstration. You can 
rerun the sample program at any time by repeating Step 16 of this Appendix, and its subsequent steps. To 
stop a running Python Program, simply click the              Reboot Target button. 
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