Home/Support/Support Forum/Cannot connect my X4 gateway to the idigi server
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Cannot connect my X4 gateway to the idigi server

0 votes
I have set up my X4 gateway and can connect to it through the IP address, but I cannot get it to connect of the iDigi platform. Once I add the device it shows up with the device type and IP address listed, however as soon as I click OK it is listed at Disconnected with only the mac address and device id information in the 'Devices' list.

On the IP link under Management -> Connections I have no TCP connection.

Any suggestions? Am I missing something obvious?
asked Jul 1, 2009 in Device Manager by keeley New to the Community (4 points)

Please log in or register to answer this question.

28 Answers

0 votes
Have you taken a look at the Getting Started guide (If what you got is a Kit)?

Did you configure the remote management portion of the device? If you go into the web interface on the device and click on 'Remote Management' link under 'Configuration' section you can enter a host name for the iDigi server.

If you have done that already, could you select the System Information link, under the Diagnostics tab, and type in the host name for the iDigi server?

If the server is pingable from the device, I would double check to make sure you provisioned it right on the iDigi server: https://developer.idigi.com/login.do

If the server is not pingable, please put your device on a network to contact the server. You may also want to try pinging www.google.com or something to verify your internet connection from the X4.
answered Jul 1, 2009 by mkotasek Community Contributor (50 points)
0 votes
I added the digi server to the remote management section and it is pingable.
I am assuming by provisioned it to the iDigi server you are talking about adding my gateway to the 'Devices' section.
To add my X4 (following the Getting Started Guide)I selected 'Add Devices', typed in the mac address, hit discover and then,once the device was shown in the list, clicked OK.

After hitting OK and launching the iDigi Device Manager is when I run into the issue... even though the IP address is valid and the device is pingable it doesn't show up as connected to the iDigi platform.
answered Jul 1, 2009 by keeley New to the Community (4 points)
0 votes
The method you describe 'should' automatically program your discovered device to point to the iDigi Connectivity Server. This is the server mkotosak was referring to and it needs to be accessible by your device.

You can find out the name of your assigned connectivity server by logging in to the iDigi portal - it will be shown in the upper left corner of the screen). You can verify that the device is properly configured to connect to that server by browsing to the web interface of your device and look at the RemoteManagement connection settings. You should see the connectivity server listed in the 'Server Address' field of the client initiated management connection section.

If this looks correct, verify that the device can ping the remote connectivity server as mkotosak suggests. It could be that the 'Add Device' function properly configured your device but that the device is on a network where it cannot reach the connectivity server.
answered Jul 1, 2009 by jeffry New to the Community (5 points)
0 votes
Oops... the name of the connectivity server is displayed in the upper RIGHT corner!
answered Jul 1, 2009 by jeffry New to the Community (5 points)
0 votes
I have added the server shown in the iDigi Platform to the Remote Management section of the web ui.
I can ping the server from there but it still does not show up as connected.
Could this have to do with a TCP connection? or a blocked port?
answered Jul 1, 2009 by keeley New to the Community (4 points)
0 votes
Well thats certainly possible if your gateway or routers are blocking ports - the device will attempt to connect to port 3197 of the connection server.

I want make sure that you are pinging the connection server from the device as max suggested and NOT from your PC. If you've done it from the device eliminates the possibility of DNS lookup errors as one possible culprit. We usually see this happen if you've set up static IP address assignment and don't properly configure the gateway.
answered Jul 1, 2009 by jeffry New to the Community (5 points)
0 votes
I set up at static IP and am pinging from the web
Admin->System Info->Diagnostics (which worked).

I'll ask if that port is blocked.

Do you know if there is a way to download a program or server to my computer so my data doesn't have to leave my network in the first place? (sorry that's a little off track)

Thanks for your help!
answered Jul 1, 2009 by keeley New to the Community (4 points)
0 votes
Connection to the connectivity server is important for remote management of the device and for use of iDigi services such as web service messaging. However, you can use Dia presentations that send data directly to other systems in your network. See the 'iDigi Dia 103 - Presentations and Transforms' link on the Resources page of the iDigi web portal for more info on that.

I am wondering if something in your device configuration is amiss. If you don't mind resetting your device configuration try this:
1. From the devices web page, reset your device to its factory defaults (feel free to keep your network settings).
2. From the iDigi portal, select the device and remove it.
3. From the iDigi portal, re-add the device using the same procedure you originally used (add device, discover, ok).

This process will reset the remote management connection settings to their original state. The fact that your device can ping the server should mean that your network, gateway,and DNS settings are good. I am therefore suspicious that the remote management connection is never being attempted. Give this a try and see if it works.
answered Jul 1, 2009 by jeffry New to the Community (5 points)
0 votes
After re-reading your notes, it looks like our add device procedure may have led you down the wrong path. When you add the device in iDigi, there are actually TWO ways to do it:

1. Manual add/configuration.
You can type in the mac address of the device and click the ADD button and then click OK. If you do this procedure then you need to go configure the remote management settings in the device too. This is the process described in the Getting Started guide.

OR

2. Automatic discovery/configuration
You can simply click the DISCOVER button and the page will attempt to automatically discover any devices nearby and puts them into the list. Remove any devices you don't want included and then click OK. If you follow this procedure then the remote management settings of the device will be automatically configured. This is a shortcut method that is not discussed in the guide but is typically quicker and simpler.

It looked from your earlier posting that you had actually tried a combination of the two and that may have caused some confusion in the tool. We should probably make that choice clearer in both the dialog and the guide.
answered Jul 1, 2009 by jeffry New to the Community (5 points)
0 votes
Im having identical issue, and yep I can ping the server.
answered Aug 2, 2009 by greggf New to the Community (1 point)
...