Home/Support/Support Forum/Restore firmware Connect ME 9210
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Restore firmware Connect ME 9210

0 votes
Hi,

I was wondering If there was a way of restoring the original firmware that was shipped with the chip (or forcing the upload of new firmware). The current firmware I have on the chip crashes and stops being responsive to ping 5 seconds after startup, so I cant use chip's FTP server to upload new firmware.

I read somewhere that shorting two pins would force a recovery from the backup image but I dont know what two pins to short.

Any ideas?

Thanks
asked Sep 10, 2009 in NET+OS by adamp New to the Community (21 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

11 Answers

0 votes
Hi,

You can try to recover the module with the following procedure.

1. Turn off power switch on development board.
2. On the twenty pin header labeled "P3" (located to the left of the ME-9210 module, next to the two pushbuttons), jumper pins #16 and #20.
3. On the 4 pin header labeled "P9" (located close to the power connector), jumper pins #3 and #4.
4. Turn on power switch.
5. Watch the output of the serial port for the message "Starting Recovery…" on the serial port at 9600/8/n/1 no flow. When you see the C’s coming, start up your Xmodem and transfer the files..
answered Sep 13, 2009 by sbrown New to the Community (48 points)
0 votes
I'm afraid that didn't work, I connected pin #16 and #20 together on P3, and #3 and #4 together on P9, turned the power on but nothing was written to the serial port.

Any other suggestions? And also, is there documentation somewhere about those two header pin sets: P3 and P9? I havn't found any so far.
answered Sep 14, 2009 by adamp New to the Community (21 points)
0 votes
Hi,

You can find the schematic diagram for the ME-9210 development board on the Digi support website at the link shown below.

The location of the P3 header can be found at the lower left corner (A-5) of page one.

The location of P9 is along the middle of the left edge (C-5) of page one.

http://ftp1.digi.com/support/documentation/30006001_05revA.PDF
answered Sep 14, 2009 by sbrown New to the Community (48 points)
0 votes
I've tried everything you have suggested, essentially putting the Connect ME pins 20 (INIT pin) and 18 (MFGI Pin) to ground but there still is no output on the serial port.

Is there other documentation somewhere detailing the procedure to force the chip into a reset and load new firmware onto it?
answered Sep 15, 2009 by adamp New to the Community (21 points)
0 votes
Wow! That worked! Now do you have a solution for non-9210 MEs? I have piles of dead regular ME modules.

-Erik
answered Sep 17, 2009 by egawtry Veteran of the Digi Community (349 points)
0 votes
Have you checked to be sure a reset pin is not tied to ground? Another thing to look for is “solder whiskers”. When the board is soldered (especially when wave soldered) there can be microscopic shorts can develop.

Are all the unused pins (of the module) left floating and not tied to anything?

Looking at the Hardware Reference guide, be sure to be following the power supply guidelines (and warnings) stated on pages #47 and 48. Improper power supply parameters may cause operational problems. The power supply could be operating at the edge of the specs allowing some, but not all modules to operate properly.

This remainder of this post is really directed towards Erik whom was wanting some information recovering other ME modules. I hope this helps you out.
answered Sep 18, 2009 by sbrown New to the Community (48 points)
0 votes
Hello,
I have Digi ME 9210 module and the TFTP recovery didnt work. At first I tested successfully the firmware on digi ME 9210 with JTAG. Then I uploaded the firmware and rom image via one FTP transfer in to the digi module and the module seems to be stuch at recovery mode. I have the DHCP and TFTP setup done (I can see the TFTP transfer in wireshrak and in server log). But the module didnt reboot and afret reboot it again searches for new image.

Any idea what to do?
answered Mar 15, 2010 by kubiajir Community Contributor (61 points)
0 votes
Make sure that you are trying to deploy a release version of image.bin. I would suggest building the FTP File System Server sample and trying to deploy that.
answered Mar 17, 2010 by mcarver Community Contributor (108 points)
0 votes
The same firmware is working in another newer digi module (this one is little bit old cca from 5.2008). The module was damaged during removal from target application, so I cant test it any more.
answered Mar 18, 2010 by kubiajir Community Contributor (61 points)
0 votes
Hi sbrown,

Where did you find this information about restoration? Because, I really searched a lot in the manual and did not find this information ...
Thanks.
answered Apr 4, 2012 by alcarafe New to the Community (3 points)
...