Home/Support/Support Forum/Connect ME -S: 6-3-1 blink code?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Connect ME -S: 6-3-1 blink code?

0 votes
Tried to upload the latest firmware in a Connect ME -S, but now I've got a 6-3-1 blink code on the green LED at bootup.

I've searched the knowledge base and the forum, but can't locate any description. Does anyone know what the 6-3-1 means?
asked Mar 30, 2009 in Plug N' Play by newell New to the Community (43 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

4 Answers

0 votes
I came across this explanation for the 6-3-1 blink code. I hope it helps you determine what is wrong.

6-3-1 BOOT_LOADER FAULT UNDEFINED_INSTRUCTION
answered Mar 31, 2009 by sbrown New to the Community (48 points)
0 votes
Thanks.

I wonder if the Digi firmware is corrupt? Surely the module wouldn't accept the firmware (I think it was the POST update that killed my module) if it is for another hardware device, correct?

I downloaded them from this page:
http://www.digi.com/support/productdetl.jsp?pid=2466&osvid=0&s=53&tp=2

The files I downloaded yesterday are identical to the ones I downloaded today, so it wasn't an internet download problem.

I may be able to access the UART pins from my computer, but I don't know how to put the -ME S into diagnostic mode. Something about shorting pins together, but the docs refer to the pins on the development board, not the actual Digi Connect ME module. Grr.

What happens if I send the 4MB POST image to a 2MB Connect ME? The packing pouch is marked "Connect ME-S", "DC-ME-01T-S", and "95011322A", so I think these are 2MB modules and I sent over the 4MB image.
answered Mar 31, 2009 by newell New to the Community (43 points)
0 votes
If you follow the KB article here: http://www.digi.com/support/kbase/kbaseresultdetl.jsp?id=804 you can recover your module. It references the dev board, but the schematic of the dev board is on the link you posted. It talks about shorting pin 18 to ground. Also, if there are no '4MB' markings on the module, you got a 2MB version, which means that's why it's now blinking in a 6-3-1 since you updated with the wrong image. If you recover using the right image, it should be fine.
answered Apr 6, 2009 by charliek Veteran of the Digi Community (408 points)
0 votes
Yeah, I tried that. I couldn't ever get the 'bricked' module to give me the diagnostic menu over the serial port. I did try the pin 18 method with another known good module, and on that one I did see the diagnostic menu. So I'm pretty sure that the recovery method doesn't work.

Seems like someone else on the forum mentioned uploading a 4MB image into a 2MB module and never being able to recover either.

I'd *love* to submit a bug report on this and a few other things...
answered Apr 6, 2009 by newell New to the Community (43 points)
...