Home/Support/Support Forum/Use a static IP address only
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Use a static IP address only

0 votes
IAM:Got STATIC IPv4 address 10.0.0.5 on interface eth0
IAM:Got AUTOIP IPv4 address 169.254.199.71 on interface eth0:0

How can I disable AUTOIP? The unit should only have the static IP address 10.0.0.5.


Message was edited by: compie
asked Sep 27, 2007 in NET+OS by compie Community Contributor (55 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

4 Answers

0 votes
I'm already using this setting:

#define APP_ENABLE_AUTO_IP APP_ON_NO_INTERFACE

but it's not working...
answered Oct 2, 2007 by compie Community Contributor (55 points)
0 votes
Have you tried:

#define APP_USE_STATIC_IP TRUE
answered Oct 7, 2007 by egawtry Veteran of the Digi Community (347 points)
0 votes
Yes I have.
But the unit still gets a 169.254.x.x address.
answered Oct 16, 2007 by compie Community Contributor (55 points)
0 votes
"gets"? You are using a static IP, there are the defaults set by APP_IP_ADDRESS, APP_IP_SUBNET_MASK, and APP_IP_GATEWAY. You can then use customizeSaveIPParameters() to change it programatically. (Don't forget to reboot after changing it with customizeSaveIPParameters().)
answered Oct 16, 2007 by egawtry Veteran of the Digi Community (347 points)
...