Home/Support/Support Forum/MAC Address / NVRAM Lost issue
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

MAC Address / NVRAM Lost issue

0 votes
1. If you add items to the end of structure devBoardParamsType should the NVRAM settings be invalidated? I am losing my MAC address after updating the image.bin.

2. If I should not be changing devBoardParamsType at all, what can I use to save misc NVRAM settings?

3. If I should be able to append items to that struct, what am I doing wrong that things are getting invalidated/reset?

Thanks,
Eric
asked Oct 15, 2007 in NET+OS by ezimmerman New to the Community (9 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

2 Answers

0 votes
It seems like it is lost any time I make a change to devBoardParamsType...

Does anyone know how I can save some items to NVRAM without causing the MAC Address to be lost?
answered Oct 15, 2007 by ezimmerman New to the Community (9 points)
0 votes
I figured out a way, but I'm still interested in those who have modified devBoardParamsType. There is a size in the structure meant for detecting an increased number of settings, but it is not used. I am wondering if anyone has implemented this..

fyi: I froze the devBoardParamsType structure, created a new structure and wrote it directly after the devBoardParams in NVRAM. I used an ID to detect whether this was the first time written to and to initialize certain parameters accordingly. Worked nice.
answered Oct 16, 2007 by ezimmerman New to the Community (9 points)
...