Home/Support/Support Forum/WieM: WPA_PSK with AES is not working....
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

WieM: WPA_PSK with AES is not working....

0 votes
Dear Friends,
My DIGI board WieM works fine for WEP and WPA-PSK with TKIP securities. But when I set WPA-PSK with AES (security = WLN_ENCR_CCMP) then API wln_params() is throws an error.Please help me to resolve this. Other than encryption key (TKIP/AES) is there any changes between TKIP and AES ?
THanks in advance


Message was edited by: devid
asked May 7, 2007 in NET+OS by devid New to the Community (6 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

6 Answers

0 votes
You mean the call to wln_set_params, correct? What's the error code returned?
answered May 10, 2007 by charliek Veteran of the Digi Community (408 points)
0 votes
-1 ....i am working with older version of Netos.. not with latest version
answered May 11, 2007 by devid New to the Community (6 points)
0 votes
The error is returned because one of your settings is invalid in the structure you passed to the function. Try putting a breakpoint on wln_set_params and step through the code until you see on which member the error is occuring.
answered May 11, 2007 by charliek Veteran of the Digi Community (408 points)
0 votes
You are corret. But there is no issue till wln_set_params () function. But once i execute this it returns -1. DO u you have any idea of parameter differs from WEP and WPA-PSk with AES.
answered May 16, 2007 by devid New to the Community (6 points)
0 votes
Sure, you need to set the WPA options such as the wpa_psk, authen, encrypt, etc. However, you do have to fill out the whole structure, not just the parts you want to change. If you're not already, try getting the current structure first using wln_get_params, modify what you want to change the encryption, authentication, keys, etc, to, and then call wln_set_params.

If you're still having problems you need to debug as mentioned above.
answered May 16, 2007 by charliek Veteran of the Digi Community (408 points)
0 votes
hi devid, i noticed you got the connect wi-em working for wpa-psk with tkip security. I'm trying to get wpa-psk with tkip security working on a connect wi-me but have had no success. Could you lend me some pointers on how you setup the wireless parameters? I'm assuming there won't be much difference between the wi-em and wi-me.

This is a summary of my current configuration:
authen = WLN_AUTH_WPA_PSK
encrypt = WLN_ENCR_TKIP
wpa_psk = <32 characters>

The access point has also been configured for these settings. Please let me know if there are other fields I need to set explicitly?
answered Sep 24, 2007 by fyicc New to the Community (18 points)
...