Home/Support/Support Forum/Is the MAC address always preserved when flashing firmware to a new module?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Is the MAC address always preserved when flashing firmware to a new module?

0 votes
I assume that the code loaded on a "factory fresh" Connect Me module is based on a "NET+OS Project", like one that can be created using the Digi ESP IDE. And I would assume that the BSP parameters in that project are the same as the default parameters when you create a new NET+OS Project. Are these assumptions correct? If they are, and Digi "guarantees" to continue to use such code on factory fresh modules, then the MAC address should be preserved (i.e. can be read from the devBoardParams structure in NVRAM) during a firmware upgrade, assuming that the new firmware does not overwrite it.

Can anyone confirm that this is true?
asked Jul 11, 2007 in NET+OS by jfichtner New to the Community (12 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

4 Answers

0 votes
The loaded firmware is basically the naftpapp example. The current revision of this firmware is 6.x and should work with any 6.x or 7.x firmware loaded onto the module (i.e. the devBoardParamsType structure in NVRAM is able to be read and if needed, converted correctly).
answered Jul 12, 2007 by charliek Veteran of the Digi Community (408 points)
0 votes
Hi charliek,
The DIGI (v0640) I have receive recently starts with the "IAM" IP addressing mecanism. It should means that it is NETOS 7.x based ?
To prove that: when I load my custom NETOS6.0F firmware into the DIGI, the MAC address is reset to default, so it should means that it is no more compatible !

Paul
answered Jul 13, 2007 by pevandenburie Community Contributor (72 points)
0 votes
It is a 7.x image, however NVRAM is setup to be backwards compatible. I've tested it before and it worked. Did you make any modifications to your devBoardParamsType structure?
answered Jul 13, 2007 by charliek Veteran of the Digi Community (408 points)
0 votes
Hi Charliek,

No I didn't made any modification on the devBoardParamsType structure, I only use it to activate DHCP or not.
I believe that the NVRAM structure has changed between NETOS6.0 and 6.3, but I'm not sure.

Moreover my application will not start after the first download. I need to reload it using the DHCP/TFTP procedure of the bootloader.

I am speaking about EM module, but I assume it is the same than DIGI Connect ME.

Thanks for any information

Paul
answered Jul 18, 2007 by pevandenburie Community Contributor (72 points)
...