Home/Support/Support Forum/Digi Connect ME raw TCP/IP so slowwww.....
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Digi Connect ME raw TCP/IP so slowwww.....

0 votes
Hi,

My raw TCP/IP socket connection is extremly slow. Running the same protocol with a direct serial port connection is 10x faster.

What can I do to improve the network speed, no there is nothing else on the network....

Would it help to adjust buffers or it the Digi ConnectME just slow???
asked Jan 18, 2007 in Plug N' Play by frank New to the Community (4 points)
recategorized Dec 18, 2013 by tuxembb

Please log in or register to answer this question.

8 Answers

0 votes
What do you mean by slow? I download firmware updates (image.bin) to the ME in about 30-50 seconds, that is 850K. I agree that is slow, but not as slow as the serial port.

Are you using the Dev Kit or Integration Kit? (In other words, did you write the communications stuff youself?)

-Erik
answered Jan 19, 2007 by egawtry Veteran of the Digi Community (349 points)
0 votes
Hi,

My DigiCOnnectME run the latest standard firmware - updateded it the other day.....

I use standard raw TCP/IP with no handshaking with the serial port setup for 230kbaud connected to an embedded micro controller with no handshake signaling.

I use a ModbusTCP protocol so it is packet based with between 20-30 bytes per transaction. When I run a serial cable between the micro serial port and a PC using the same ModbusTCP protocol.....it runs consistantly at a deterministic rate much higher that the eratic behaviour observed when communicating using the raw TCP/IP mode.

Any suggestions....
answered Jan 20, 2007 by frank New to the Community (4 points)
0 votes
Please note that the ModbusTCP protocol is implemented on the micro controller. I did not modify the code on the standard DigiConnectME.

Thanks
answered Jan 20, 2007 by frank New to the Community (4 points)
0 votes
Then are you sure the problem is the Digi?
What abou the connection with the micro and the ModBUS libraries?

-PC
answered Jan 23, 2007 by PC New to the Community (32 points)
0 votes
Looking at the specs for the ModbusTCP protocol, I don't see how you can implement it without modifying the code in the ME. Since the ModbusTCP works by embedding extra codes in the TCP protocol, it would need to have specific support. If you are somehow kludging it in there externally (prebuilding the packets?), that may not be an issue, but you are still limited by the speed of the micro.

Are you using SLIP or PPP to get into the Digi? Otherwise I don't see how you are connecting to it on the serial side.

-Erik
answered Jan 25, 2007 by egawtry Veteran of the Digi Community (349 points)
0 votes
Try from Telnet :
set service range=5 nodelay=on

the service I use is TCP server which is service 5.

otherwise the device waits till it has a decent size packet, or long time elaspes. I have more info on this subject. Be aware that network traffic will increase substantially.

glen
answered Feb 13, 2007 by glenenglish New to the Community (2 points)
0 votes
Are you using a NetOS pre-built service? That may be your whole problem. They access the internal flash inside the algorythms which is very slow (sometimes > 5 sec). I gave up on the pre-built servers in the ME years ago. It is easy enough to write any one that you need. I have no delays at all with the servers that I am running simultaneously:

telnet
ssh
TCP socket

Also I am running these clients:

telnet (15 of 'em)
nist
TCP socket

So any delays must be in the pre-built code.

-Erik
answered Feb 14, 2007 by egawtry Veteran of the Digi Community (349 points)
0 votes
>Try from Telnet :
>set service range=5 nodelay=on
>
>the service I use is TCP server which is service 5.
>
>otherwise the device waits till it has a decent size >packet, or long time elaspes. I have more info on this >subject. Be aware that network traffic will increase >substantially.
>
>glen

Dear Glen,

The solution you provided, solved my problem for the standard pre-build DigiConnectMe. However this setting can only be alterd through Telnet. There is no parameter of this kind exposed in the HTML interface.

Thanks very much


Message was edited by: frank
answered Feb 16, 2007 by frank New to the Community (4 points)
...