Home/Support/Support Forum/Problem with Ethernet, Digi ME, S-type
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Problem with Ethernet, Digi ME, S-type

0 votes
Hello,
I'm running linux-2.4 on a DigiME S-Type since 2005.
Some 100s installed and working fine.

Now my customer ordered again 200 pieces.

On these new ME's there seem to be changes in the ethernet PHY.
The PHY is reported as ICS1893BF. But I can't access the registers correctly.
For example, the "Quick Poll Detailed Status Register" doesn't reflect the values read.

My question:
does anyone know about hardware changes concerning the ethernet interface on the ME since 2008.
Last bought ME's from 2008 are working fine.

Thanks,
Siegfried
asked Oct 4, 2010 in Plug N' Play by poldi New to the Community (2 points)
recategorized Dec 5, 2013 by tuxembb

Please log in or register to answer this question.

3 Answers

0 votes
I think you've identified the problem - there was certainly a change in one of the components of the ME.
Digi published a software update which supports the new PHY, and recompiling with that update included should sort the problem
answered Oct 4, 2010 by steved2 Seasoned Professional (183 points)
0 votes
Thanks for the quick response.

I would need some more help, please.

Some years ago there was already a change in the PHY (change from Intel LX-Type to the ICS-Type).
I adapted my software by using the netos-6f-lsk sources of the "netos60_gnu"-package, file
"netos60_gnu/src/bsp/platforms/connectme_lsk/MII.c"

According to the advance of "steved2" I searched the whole site for updates and other files.

The only update I could find was "40001928_F.iso" from 2004 and a patch file which doesn't contain
changes for the PHY.

I admit I'm not absolutely up to date concerning Digi upgrade policy and other changes, because the software
was running very fine up to now. "Never change a running system" ;-))

Therefore my questions:

1. Does anybody know where I can find the software update mentioned by "steved2"?

2. Is it possible to download an upgrade from netos-6 to the present version (sources), or, if not, where to buy?

3. Or is there even an up-to-date linux ethernet driver availalble on the net which I can take as a template for my changes?
Up to now I could only find very old versions of the linux "ns7520_eth.c" which don't even reflect the changes for the ICS-PHY.

One additional question:
during my search I found the document "http://ftp1.digi.com/support/documentation/netoserrata.txt". In this file a "customizeMiiSetSpeed()" problem
is mentioned and a cross-link to a workaround "[19738]". I can't find it either on the site. Where to search?

Thanks in advance,
Siegfried
answered Oct 5, 2010 by poldi New to the Community (2 points)
0 votes
Latest news and close:

for those people who will struggle with the same problem. I've got the solution of my problem
by empiric testing.

The PHY seems to be a ICS1894 (look at: PHY ID register 2).
To adapt from ICS1893BF you have to change at least:

MDIO clock:
fix to 2.5 MHz

ICS1894 registers:
adapt registers according data sheet. With ICS1893BF one could use registers 9 through 15h, which are
reserved by IEEE on ICS1894.
There is a possibility to access "old" ICS1893 registers by bank switching. I didn't try that,
because successors won't use that registers either.

Support answers from Digi to my customer:
1. Use the C-Type
2. Silence ;-))

My linux on ME works again and has transferred tons of data in the crash tests during the past days.

Hope that it will help anybody out there

Siegfried
answered Oct 12, 2010 by poldi New to the Community (2 points)
...