Home/Support/Support Forum/FtpPutFile failed, error: 6
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

FtpPutFile failed, error: 6

0 votes
Hello Guys,

Well am starting in the great world of the Digi devices.
I'm working Digi Connect ME and learning about the re-flashing ways using the NET+OS Programmer software line command to upload files and trying to update the default firmware have stopped by the next error:

NET+OS Programmer
Version 1.2.9.0
Copyright 2004-2005 NetSilicon Inc.

Searching for devices. Please wait...

Locate device (auto): SUCCESS
Uploading firmware...
FtpPutFile failed, error: 6


This is the line command that am using:

netosprog /discover
netosprog /upload /mac=auto /firmware=rom.bin


Somebody here with the same issues in your first fighters..

I'll appreciate your help.

Best Regards. [:D]
asked Apr 11, 2012 in NET+OS by federz New to the Community (0 points)
recategorized Dec 4, 2013 by tuxembb

Please log in or register to answer this question.

1 Answer

0 votes
Make sure the rom.bin file is not too large this will cause a problem, for me I got an error my file was too large, see below:
I would recompile the application in release mode again to get a new rom.bin file.

C:\netos75\bin>netosprog /upload /mac=auto /firmware=rom.bin
NET+OS Programmer
Version 1.3.15.0
Copyright 2004-2009 Digi International Inc

Searching for devices. Please wait...

Locate device (auto): SUCCESS
Uploading firmware...
FtpPutFile failed with error 12030

On my serial termnial I got the error below, you might want to check your terminals output.
FSStoreImageToFlash NAFlashWrite() error -12.

Another thing you might want to check is that your board is still connected and you did not loose connectivity to it. A good way to check is to have a continous ping. Also a trace will help see why it failed.
answered Apr 11, 2012 by Campbell Veteran of the Digi Community (839 points)
...