Home/Support/Support Forum/Connect ME bogging down on high traffic network
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Connect ME bogging down on high traffic network

0 votes
I've done most of my development with the Connect ME connected directly to my development PC via a second NIC card and a crossover cable. I recently attempted to connect my device to my company's LAN and ran into some strange issues.

Pinging the device from the network results in slow response times and lost packets. When connected directly via crossover cable, I can ping indefinitely with a <1ms response time. I have a diagnostic web page on the device that shows "packets received since power-on", and I notice that when it's connected to the network, this number is constantly increasing at a pretty fast rate. This leads me to believe that the Connect ME is somehow getting bogged down trying to interpret the data on the network. I'm not familiar enough with TCP/IP to know how the module is supposed to handle this traffic, but I know that other devices on the same network respond to pings in<1ms, so something must not be right.

Any suggestions as to what might be happening here?
asked Jan 30, 2013 in NET+OS by jfichtner New to the Community (12 points)
recategorized Sep 20, 2013 by tuxembb

Please log in or register to answer this question.

1 Answer

0 votes
Well let's assume your network has a high degree of broadcast traffic. You could try the following as an experiment. Give your device a STATIC IP address. Then use the API NABlockUDPBroadcasts() (described in the API reference manual). If your performance goes up, then your device is being pummeled by broadcast packets. If you read the entry you'll see that to use this your IP address must be statically acquired as the device will ignore DHCP activity. But doing so might give you some insight on what is going on.

That said, since you do not say, I am assuming the use of the NET+OS development environment. If you are, instead, using LINUX or one of the other development environments then ignore all of the above.
answered Jan 30, 2013 by dakotas_dad Veteran of the Digi Community (694 points)
...