Home/Support/Support Forum/How can I read "Hello World" in the console?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How can I read "Hello World" in the console?

0 votes
Ciao,
I'm a new Digi Connect Me user.
I'm trying to run the "Hello World" application in this way:
1. Open Sample Project
2. Compile it
3. Update device's flash
.....
and then?
How can I use this application?
Where can I read the "Hello World" string? in the console?
What is it the correct setting of the serial port? 9600,8,none,1,none?
What have I to select as debugger?

Pls, HELP ME....
I know my questions are very stupid [:((]
but I don't find this informations from anywhere

Thanks
asked Feb 18, 2013 in NET+OS by daniele New to the Community (1 point)
recategorized Sep 20, 2013 by tuxembb

Please log in or register to answer this question.

3 Answers

0 votes
When you build application it is builded in debug mode by default. You can change that in project properties by making Debug/Release mode as "Active".

So for trial i will not suggest flashing the image onto flash.
You can follow the below procedure:-

1.Build in debug mode.
2.Connect Digi JLink JTAG debugger to PC via usb and connect debugger to dev board.
3. Right click on project and click debug.
4. This should debug your application via debugger.
You can see the o/p in standard serial terminal in the baudrate what you have mentioned. This the default settings.
5. Debugger will pause at a break point and click continue.
6. You can see o/p in serial terminal.
7. Digi ESP has inbuild serial terminal. You can select it from Windows option.
answered Feb 20, 2013 by tuxembb Veteran of the Digi Community (288 points)
0 votes
Ciao,

thanks for your answer.
I tried as you suggest me.....but nothing to do.
I'm thinking that the application image is not flashed in the module.
How can I check?

I remember, few months ago, with windows XP I have not had this problem.
Now, with windows 7.....
Do you think there is a relation with the OS in my pc?.

Thanks a lot.

Bye
answered Feb 22, 2013 by daniele New to the Community (1 point)
0 votes
Hello can you see any output on the serial console? Something like the output below: If you can not see similar output weather you flashed the device or you are using a jlink then your terminal must be disconnected. If you can see output when using the jlink debugger but not after you flash the image.bin into the module then the image might be corrupted. When rebooting the board after you reflash the image.bin file make sure the jlink debugger is disconnected from the dev. board.

Output from Serial console
NET+OS Version 7.5.2.2
Copyright (c) 1997-2011, Digi International, Inc.

PLATFORM: connectwime9210 4M/8M [Aug 24 2012 14:09:04]
APPLICATION: Ram-based FTP Server Application [Aug 24 2012 14:11:36]
NETWORK INTERFACE PARAMETERS:
The board will obtain wireless IP configuration parameters from the network.
Wireless country name configured is United States
Wireless protocol mode is for access point (infrastructure) networks only
Wireless SSID is Digi
Frequency band is band bgn
Wireless channel is 10
Wireless transmit rate is auto
Wireless spectrum management (802.11h) and multi domain (802.11d) enabled
Wireless powersave disabled
Authentication type = WPA/WPA2 Personal (WPA-PSK)
Encryption type = TKIP
HARDWARE PARAMETERS:
Serial channels will use a baud rate of 9600
This board's serial number is N99999999
This board's Wireless MAC Address is 00:40:9D:28:08:07
After board is reset, start-up code will wait 5 seconds
Press any key in 5 seconds to change these settings.
answered Feb 25, 2013 by Campbell Veteran of the Digi Community (552 points)
...