Home/Support/Support Forum/Installing latest ntpd on cc9p9215
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Installing latest ntpd on cc9p9215

0 votes
I have downloaded unpacked, made, made install ntp from openntp.org. Can someone offer some guidance on how to move this onto my target system?
I tried just copying ythe ntpd binary into /usr/sbin but the system willl not compile, returns error cannot find libm.so.6
Thanks
asked Jan 22, 2013 in Linux by digiDave New to the Community (20 points)

Please log in or register to answer this question.

3 Answers

0 votes
ntpd package is available in DEL configuration.
Create a full project and in configure you can choose ntp.
I am not sure whether it is latest or not. But this is suffice in most of the cases
answered Jan 29, 2013 by tuxembb Veteran of the Digi Community (288 points)
0 votes
Thanks Tuxxy. Already did this but really want to install latest server from NTP project. Have moved on for now but will come back to this later.
answered Mar 13, 2013 by digiDave New to the Community (20 points)
0 votes
You get the error message "Cannot find libm.so.6" so I assume that the binary is already successfully compiled. This error is generated from the dynamic library loader at runtime.
The file libm.so is missing and it is - depending on your DigiEL version - located at <DigiEL>/usr/lib or <DigiEL>/x-tools/<platform>/<platform>/sysroot/lib. Copy this file to the /lib directory of your target systems root.
answered Mar 15, 2013 by f.kerkhoff New to the Community (7 points)
...