Home/Support/Support Forum/Touch Screen Issue
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Touch Screen Issue

0 votes
I'm using the ConnectCore 9C with Windows CE 6.0 and I'm having trouble getting the touch screen to work at all. I've looked through the Catalog View for the platform that I'm building and as far as I can tell, I have included everything in there having to do with touch screen, but it just doesn't work.

Any ideas what could be my problem?
asked Mar 7, 2008 in Windows CE by Jerry New to the Community (3 points)

Please log in or register to answer this question.

4 Answers

0 votes
Hi,

I have the same problem. I measured the SPI signals, though they look fine, so I guess you have to change the mode settings of the associated SPI. This is not a big thing, but I haven't got the time to check this yet.

If you've solved the problem by now, please let me know

regards,
Kris
answered Apr 9, 2008 by kris1 New to the Community (5 points)
0 votes
Hi,

Generally you just need to go to Third Party\BSP\[platform]\Drivers

Select your screen.
Set Serial Port B to SPI.
Enable the ADS touch controller.

Sometimes a normal clean isn't good enough. Gotta do a "Build->Advanced->Rebuild and Clean Sysgen" This takes a really long time, but it ensures that the changes you made will actually get put into your image.

I hope this helps,
Mike
answered Mar 3, 2009 by Wizard New to the Community (4 points)
0 votes
Did you verify the polarity of the SPI during read and write?
answered Mar 3, 2009 by signum New to the Community (2 points)
0 votes
Hi ,

Have you selected ,what type of touch screen are you using from the serial console ? like
At serial console
#setenv video displayfb:LQ070Y3DG3B
#saveenv
answered Mar 4, 2011 by cpigilam Veteran of the Digi Community (655 points)
...