Home/Support/Support Forum/Passthrough authentication for Digi Portmaster 16
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Passthrough authentication for Digi Portmaster 16

0 votes
I am 90% of the way complete with the configuration of this portmaster, and didnt see my problem in the FAQ or forum, so here is my question:

I have assigned the Digi portmaster16 an ip address and subnet and is sitting on my network working correctly (i can telnet to it, login as root, and make configuration changes as necessary)

what i need this thing to do, is pass through and bring up directly, a login prompt to the server that users will authenticate against.

i have turned off login and password (both set to off) however now all i get is a 'Digi>' prompt
and i still have to type 'telnet [host] to get to the host and then authenticate to login. what i want this thing to do is, upon connect, either by modem or wyse terminal, is bring back a login prompt to the HOST, not have to telnet first, then login. what changes do i need to make to the port on which i am connected:

Below is the configuration for the individual port on which im connected:

BEGIN
==============================================
set ports range=4 termtype="wy150" dev=term sess=4 uid=0 edelay=1
set ports range=4 auto=off bin=off group=0 dport=0 dest=255.255.255.255
set line range=4 baud=9600 csize=8 parity=N stopb=1 break=ignore
set line range=4 error=null inpck=off istrip=off onlcr=off otab=off
set flow range=4 ixon=off aixon=off ixoff=off ixany=off itoss=off altpin=off
set flow range=4 rts=on dtr=off cts=on dcd=off dsr=off ri=off
set keys range=4 eof=^D erase=^H flush=^@ intr=^C kill=^E lnxt=^V
set keys range=4 tesc=^] xon=^S xoff=^Q xona=^S xoffa=^Q
set logins range=4 cmdprompt="digi>" logprompt="Enter medea>"
set logins range=4 passprompt="passwd:"
set logins range=4 write=off login=off passwd=off verbose=off
=======================================================
END

Thank you all in advance for any advice on this problem
asked Jan 14, 2004 in Portserver TS by javadog New to the Community (12 points)

Please log in or register to answer this question.

18 Answers

0 votes
To configure a port to automatically connect to a host:

#> set port dev=term auto=on dest=(IP_address_of_host) range=(port#)

For example, to configure port 16:

#> set port dev=term auto=on dest=192.168.0.0 range=16

This will automatically connect to the host IP address provided in the 'dest' field when a key is pressed on the terminal or PC attached to port 16.

Hope this helps.
answered Jan 14, 2004 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
outstanding!

i will be making these changes in a couple hours and test, i will post the results, and i expect it to work.

thank you again

ps, second addition to this question:

i have been using a wyse terminal to test and make sure that everythiung is working right from the DIGI into the network, one more snafu i need to add to the solution. I will be replacing the wyse with a modem for a remote dialin to connect to our systems. besides changing the baud rate, hardware flow, ect for connecting via modem, will that pass-through string for connecting directly to the internal server (via ip address) stay the same? or will i need to modify the internal connect string for auto-connect to our intermal machines.

basically....is the connect parameters different for modem over terminal? or are they essentially the same, and i just need to set the port up to accept a modem connection?

thank you again for your help

-Andrew
answered Jan 14, 2004 by javadog New to the Community (12 points)
0 votes
Yes, this configuration will work with in-bound modem connections.


Tip: With modem make sure the DCD signal is being asserted properly. If you are attaching the modems using an 8-wire (non-Digi) cable, you will need to activate the altpin setting:

#> set flow altpin=on range=(port_#)
answered Jan 14, 2004 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
ok, i got the wyse connecting through just fine. working to log directly into the server via pass through to the ip address.

now ive set the modem up, set baud, hardware flow control, software flow off, ect

i also set that last command {set flow altpin=on range=(port_#) } on the port that im connecting to. curious though i get the modem noise on dialin, i get what Hyperterminal says is 'connected' however, hitting the enter key does not bring back a login prompt for me to login to the server.

two questions:

1.) is there a commmand i can run against the digi to print to screen the full configuration of the port so i can post it in here for anyone to see.

2.) prob cant answer number two (what ive done wrong) until someone sees the output of the port.

thank you again for your time,

talk to you soon

-javadog
answered Jan 14, 2004 by javadog New to the Community (12 points)
0 votes
also to note:

the connection is as follows:

25pin conector that then connects to a standard rj-45 network cable (the network cable is standard pinout for tcp/ip connectivity and has NOT been modified)

i get modem noise back, Hyperterm tells me im connected, but i hit the enter key and do NOT get back a login prompt to my Unix box like i did when the wyse terminal was hooked to this port.

thank you again for your time

-javadog
answered Jan 14, 2004 by javadog New to the Community (12 points)
0 votes
also, here is the output of the port info currently:

1 vt100 term 4 0 1 off off 0 0 255.255.255.255
2 wy150 term 4 0 1 off off 0 0 255.255.255.255
3 wy150 term 4 0 1 off off 0 0 255.255.255.255
4 wy150 mio 4 0 1 on off 0 0 192.168.1.1 (changed to generic for security reasons)
5 wy150 term 4 0 1 off off 0 0 255.255.255.255
6 wy150 term 4 0 1 off off 0 0 255.255.255.255
7 wy150 term 4 0 1 off off 0 0 255.255.255.255
8 wy150 term 4 0 1 off off 0 0 255.255.255.255
9 wy150 term 4 0 1 off off 0 0 255.255.255.255
10 wy150 term 4 0 1 off off 0 0 255.255.255.255
11 wy150 term 4 0 1 off off 0 0 255.255.255.255
12 wy150 term 4 0 1 off off 0 0 255.255.255.255
13 wy150 term 4 0 1 off off 0 0 255.255.255.255
14 wy150 term 4 0 1 off off 0 0 255.255.255.255
15 wy150 term 4 0 1 off off 0 0 255.255.255.255
16 wy150 term 4 0 1 off off 0 0 255.255.255.255
answered Jan 14, 2004 by javadog New to the Community (12 points)
0 votes
I'm a bit leary of the pinout you mentioned. You might want to compare how the RJ-45 to DB-25 pinout you're using compares to the following:

http://support.digi.com/support/techsupport/common/cables/async/modem_rj45-8pin-altpin--db25m.htm

If the pinouts are correct, you should be seeing a login once you connect to the port.
answered Jan 14, 2004 by michaelt Veteran of the Digi Community (758 points)
0 votes
i need to build that now,

that is NOT the same pinout that i currently have,

so lemme get that built, and reconnect. think that im missing one pin, because i think i get the 'ack' just not the 'nak' *smile*

thank you a ton for the link. building cable now

-javadog
answered Jan 14, 2004 by javadog New to the Community (12 points)
0 votes
i havent built the cable yet, and here is why: tell me if i F'd up and i just need to build it.

we have the identical digiport 16 that has modems connected to it that act as fax servers

i 'borrowed' one of the cables that is 25 pin to rj-45, put it on my setup, same modem same digiport 16

dialed in, and this time instead of getting nothing back and hyperterminal saying im 'connected'
all i get back is a bunch of non-ascii characters when i hit the enter key and no login...

am i just wasting time, does this sound like a cable issue or a config issue?

thank you again, i feel i am on the home strech....

-javadog
answered Jan 14, 2004 by javadog New to the Community (12 points)
0 votes
At this point, using the new cable and seeing garbage, I'd say its a config issue.

Earlier in this thread, you posted the following config info from your TS:

set line range=4 baud=9600 csize=8 parity=N stopb=1 break=ignore

This lists the baud rate at 9600. Most modems would have their DTE rate at 57600 or 115200, unless specifically configured otherwise. You will want to contact your modem manufacturer to find out the AT commands to set a DTE rate on your modem. Alternately, you could try changing the "set line" speed to 57600 or 115200, and see if you get a clean login then.

Bottom line is that the DTE rate (not connect speed or DCE rate) of the modem has to match the "set line" speed of the port.
answered Jan 14, 2004 by michaelt Veteran of the Digi Community (758 points)
...