Home/Support/Support Forum/RealPort TS 16 SUSE 10
New and improved user forum site coming soon
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

RealPort TS 16 SUSE 10

0 votes

I have been able to install the dgrp-1.9-17.src.rpm driver, on SUSE 10 but when I open up the RealPort manager, it doesn't show the status of the ports as being OPEN.

If I install the software on a SUSE9 machine and open up the RealPort Manager software, the ports are showing up as being OPEN, but for some reason it doesn't work on SUSE10.

Is there a different driver that I should be using for SUSE10?

asked Sep 19, 2007 in Realport by Grevers New to the Community (3 points)

Please log in or register to answer this question.

8 Answers

0 votes
I had a similar problem when I was first trying to get the Realport software running on Fedora Core 5.

Some of the things I learned was:
1. Check and make certain that the /dev/ttyXXYY devices are actually there. If they aren't then the driver isn't loaded or running properly. You won't get very far until this is resolved.

2. When you change the port setting on the PortServer to "realport", try rebooting the PortServer. This may not always be the case (and I do have an older version), but at one point I did this and things started to work.

My observations for Fedora are here:


How did you build from the src rpm? What command line did you use?

Also, are you sure the daemons are running?

Finally, check /var/log/messages, as there might be some useful info there.

Wish I had a solution for you, but hopefully this will give you a few pointers.

The RealPort software is great, and Digi has done a fine job IMHO. But getting every support working for every different distro out there strikes me as a pain. Which I suppose is part of what the general Linux community is for.
answered Sep 19, 2007 by tux7 New to the Community (12 points)
0 votes
The exact commmands that I ran are:

rpm -ivv dgrp-1.9-17.src.rpm
cd /usr/src/packages/SPECS
rpmbuild -bb dgrp-1.9.spec
rpm -ivv dgrp-1.9-17.x86_64.rpm

When I run the rpmbuild command, I receive the following error during the build phase:

* The Digi RealPort driver is supported only on the
* Intel x86 platform!
* Attempting to continue, hoping for the best...

If I look through the release notes that come with this driver, it mentions that it's compatible with SUSE up to 9.3.

How do I get a driver for SUSE 10?
answered Sep 20, 2007 by Grevers New to the Community (3 points)
0 votes
Please try the following syntax and let us know your results:

Make sure your kernel source is installed and the symbolic link is created:

# rpm -qa | grep kernel
# uname -r

The kernel-source should match your running kernel exactly (uname -r). If not please install the matching kernel-source from your SuSE media.

# ls -l /usr/src

Verify symbolic link between kernel source directory and 'linux'. If none is there, create one:

# ln -s /usr/src/linux-(version) /usr/src/linux

Rebuild the source rpm:

# rpmbuild --rebuild dgrp-1.9-17.src.rpm
# rpm -i /usr/src/packages/RPMS/i386/dgrp-1.9-17.i386.rpm

You'll next need to add your Portserver to the driver, and can chose from either of the following methods:

From an Xterm session, configure your PortServer devices and start the associated daemons:

# /usr/bin/dgrp/config/dgrp_gui

Configuring from the command line:

# /usr/bin/dgrp/config/dgrp_cfg_node init (ttyid) (ip_address) (number_of_ports)
answered Sep 20, 2007 by michaelt Veteran of the Digi Community (772 points)
0 votes
Note also that one can usually fall back to VMWare. Their server product is free, and I've had some great success with it.

I'm sure that it isn't your preferred solution, but I mention it as it can get one out of a tight spot quickly, and give you some breathing room if you're under a tight schedule.

I've had luck with CentOS 5 as the host and guest OS. Fortunately I haven't had to use this approach with RealPort; but thought that I'd mention it in case it helps.
answered Sep 20, 2007 by tux7 New to the Community (12 points)
0 votes
The output from those commands are as follows:

# rpm -qa | grep kernel

# uname -r

# ls -l /usr/src/
total 4
lrwxrwxrwx 1 root root 20 2007-09-12 15:34 linux -> linux-
drwxr-xr-x 20 root root 4096 2007-09-12 15:33 linux-
drwxr-xr-x 3 root root 19 2007-05-18 21:59 linux-
drwxr-xr-x 3 root root 20 2007-09-12 15:34 linux-2.6.5-7.244
drwxr-xr-x 3 root root 20 2007-09-12 15:35 linux-2.6.5-7.276
lrwxrwxrwx 1 root root 24 2007-09-12 15:34 linux-obj -> linux-
drwxr-xr-x 7 root root 67 2007-05-03 23:24 packages

As you can see, the symbolic links are in place and pointing to the correct kernel version.

It does allow me to install the software, and even configure the PortServer via the dgrp_gui. BUT if I look at the status of the ports, the ports are showing up as being CLOSED. If I look at the device from a SUSE 9 machine, the ports show up as being OPEN.

It's definately pointing to a SUSE 10 issue, but I'm unable to determine exactly where the issue lies.
answered Sep 20, 2007 by Grevers New to the Community (3 points)
0 votes
The dgrp_gui application relies heavily on tcl/tk. I recommend comparing those versions with the SuSE 9 host.

Meanwhile, you may find dpa.dgrp to be more useful for monitoring port activity.
answered Sep 21, 2007 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
I've compared the versions of tcl\tk to the SuSE 9 host, and have uninstalled the newer versions from the SuSE 10 host and installed the same versions from the SuSE 9 host. I am still unable to get the comms working to the device.

If I try to perform any dgrp_ditty troubleshooting, it reports that the "resource temporary unavailable". If I look at the status of the device in the Port Manager, it won't show the speed of the port, and it doesn't show the correct status of the ports.

What else can I try?
answered Sep 24, 2007 by Grevers New to the Community (3 points)
0 votes
I recommend contacting Digi Tech. Support for more in-depth troubleshooting.
answered Sep 24, 2007 by userid0 Veteran of the Digi Community (2,158 points)