Home/Support/Support Forum/cingular url realport snafu
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

cingular url realport snafu

0 votes
I am trying to add a Digi Connect RG but RealPort Manager v 1.6 (on RedHat 8) doesn't like the Cingular url (1...internet.mycingular.com). Says it's not valid, presumably because it

Do I need to install a newer version of RealPort Manager or is there a workaround?
asked Sep 21, 2005 in Realport by miner New to the Community (6 points)

Please log in or register to answer this question.

11 Answers

0 votes
...starts with a number and realport therefore expects an IP
answered Sep 21, 2005 by miner New to the Community (6 points)
0 votes
The RealPort driver is used to access the serial port on the Digi device. It creates a tty device on your Linux host similar to the built-in serial port.

When installing the driver, you will want to use the unit's local IP address (LAN) and not the Cingular network address (WAN).
answered Sep 21, 2005 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
Thanks, but the device is not on a LAN. Cellular only. The Cingular network address (1phonenumber.internet.mycingular.com) is all I have to hang my hat on. Similarly I have an 802.11b digi that I would like to put on someone else's network, but they can't give me a static IP, only maybe a name that maps to a Dynamic IP.
answered Sep 21, 2005 by miner New to the Community (6 points)
0 votes
Oh, do you mean I should first enter the generic IP for the digi (192.168.1.1) and enter the Cingular address somewhere else? Not sure I remember having this option...
answered Sep 21, 2005 by miner New to the Community (6 points)
0 votes
The driver does support DNS.

Are you using dgrp_gui? If so, it prompts for the IP or name.

Be sure you can communicate with it from your Linux host:

ping 1phonenumber.internet.mycingular.com
answered Sep 21, 2005 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
I will try again when almighty "Root" arrives...

I am able to ping and use nslookup to get current IP.

Yes, we're using the GUI, but I could try command line if I can find that documentation.
answered Sep 21, 2005 by miner New to the Community (6 points)
0 votes
Here is the command line syntax:

/usr/bin/dgrp/config/dgrp_cfg_node init -v -v -e never a 1phonenumber.internet.mycingular.com 1

This will give you a tty device labeled ttya00.
answered Sep 21, 2005 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
Thanks. The forum was down for a while but in the meantime we got the command line to work just fine.

So the GUI (at least the one we're running) is what is broken.

Data is flowing (well, actually trickling)!
answered Sep 21, 2005 by miner New to the Community (6 points)
0 votes
Glad you were able to get it working. However, dgrp_gui seems to work fine (it uses the exact same command as the CLI). Perhaps, the "id" field was being confused with "ip"?
answered Sep 22, 2005 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
I don't think so--we tried the GUI again beforehand and the same thing happened. A little box popped up that said something to the effect of "that is not a valid IP". And it wouldn't go away. We couldn't get to the stage of actually committing the entries.
answered Sep 22, 2005 by miner New to the Community (6 points)
...