Home/Support/Support Forum/modem under sco openserver 5.0.6
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

modem under sco openserver 5.0.6

0 votes
Modem is connected to a PORTs-16 DB25 style...

used to work fine with accelleport card, but switched to a Port Server II

Cabling unchanged, same modem, etc.. (didn't even need to unplug any cables)

Server was changed as well...

Following the directions to install the modem.... I type

cu -l /dev/ttyB25 -s 38400

I get....

Connected

Lost Carrier

Disconnected
#

Please help. Thank you.
asked Mar 12, 2004 in Realport by davester New to the Community (6 points)

Please log in or register to answer this question.

12 Answers

0 votes
Some additional info...

# ditty -a /dev/ttyB25
onstr \033[5i offstr \033[4i term ansi
maxcps 100 maxchar 50 bufsize 100 edelay 100
-forcedcd fastcook -altpin -fastbaud (9600) -printer
eia232 -rtspace -dtrpace -ctspace -dsrpace -dcdpace
DTR+ RTS+ CTS- CD- DSR- RI-
startc = 0x11 stopc = 0x13
-aixon astartc = 0x0 astopc = 0x0
speed 9600 baud; ispeed 9600 baud; ospeed 9600 baud;
line = 0(tty); intr = DEL; quit = ^\; erase = ^H; kill = ^U; eof = ^D; eol = ^@;
swtch = <undef>; susp = <undef>; start = ^Q; stop = ^S;
-parenb -parodd cs8 -cstopb hupcl cread -clocal -loblk
-ortsfl -ctsflow -rtsflow
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -iuclc-ixon -ixany -ixoff
-isig -icanon min = 4 time = 0 -xcase -echo -echoe -echok -echonl -noflsh -iexten -tostop -xclude -opost -olcuc -onlcr -ocrnl -onocr -onlret -ofill -ofdel
-isscancode
-autoe -ed_emacs -ed_vi -ed_history
#
answered Mar 12, 2004 by davester New to the Community (6 points)
0 votes
If you're using an 8-wire RJ-45 rather than a 10-wire Digi modem cable, you'll need to enable the altpin parameter on the Portserver II. If you purchased the modem cable from Digi (i.e 10-wire RJ45), the altpin parameter wouldn't be necessary.

For an 8-wire RJ-45 to DB-25 modem cable, here's the correct wiring:

http://support.digi.com/support/techsupport/common/cables/async/modem_rj45-8pin-altpin--db25m.htm

Also, you'll want to connect to the ttyb25 device rather than ttyB25 for outgoing traffic like cu. ttyB25 would be used for incoming connections, such as enabling ttyB25 for remote access to your server.
answered Mar 12, 2004 by michaelt Veteran of the Digi Community (772 points)
0 votes
I am connected with a DB25 serial cable to the PORTS16 - DB25 version as I mentioned in my first post. I am not using RJ45. I know that I'm correctly cabled, because the part I changed was the controller...

from the Accelleport to the Port Server II

my PORTS16em (DB25 version) has been untouched an unchanged and was always working just fine (it's just plugged into EBI connector on the PORTServer instead of on the accelleport)

(all other ports are functioning OK, so I'm configured properly to the Port Server II)
answered Mar 12, 2004 by davester New to the Community (6 points)
0 votes
When i do...

cu -l /dev/ttyb25 -s 38400

Connect failed: NO DEVICES AVAILABLE
answered Mar 12, 2004 by davester New to the Community (6 points)
0 votes
Alright, yeah I misread that. I thought you were connecting to the RJ-45 ports on the Portserver II itself, not an attached Ports module. In that case, altpin is not necessary.

As for the problem itself, try connecting to the ttyb25 device. In order to resolve the "No Devices Available" issue, you'll need to create an entry for ttyb25 in your /usr/lib/uucp/Devices file. See "man Devices" on your SCO server for details on creating that entry. You'll probably need to chown the device to uucp:uucp as well.
answered Mar 12, 2004 by michaelt Veteran of the Digi Community (772 points)
0 votes
I have configured my modem to auto answer with...

ATS0=2
OK
AT&W
OK

It is not answering however. The DTR light on the modem is off (low), so the modem doesn't answer, even though AA is lit.

If i connect the modem the a PC's COM2: (same DB25 to DB25 cable) the DTR light on the modem goes ON (high), and it will auto answer correctly for me.

I reconnect again (same cable) to the DB25 connector of the PORT-16em driven by the Port Server II, and the DTR line goes low again, and the modem will not answer.

The strange thing is the ditty command show DTR+ for the port. I also notice DSR- and feel this may be the problem, but I'm not sure how to change that.

Please help (getting desperate here)
Thanks a million!!!!!!!
Davester

PS - ditty settings

Some additional info...

# ditty -a /dev/ttyB25
onstr \033[5i offstr \033[4i term ansi
maxcps 100 maxchar 50 bufsize 100 edelay 100
-forcedcd fastcook -altpin -fastbaud (9600) -printer
eia232 -rtspace -dtrpace -ctspace -dsrpace -dcdpace
DTR+ RTS+ CTS- CD- DSR- RI-
startc = 0x11 stopc = 0x13
-aixon astartc = 0x0 astopc = 0x0
speed 9600 baud; ispeed 9600 baud; ospeed 9600 baud;
line = 0(tty); intr = DEL; quit = ^\; erase = ^H; kill = ^U; eof = ^D; eol = ^@;
swtch = <undef>; susp = <undef>; start = ^Q; stop = ^S;
-parenb -parodd cs8 -cstopb hupcl cread -clocal -loblk
-ortsfl -ctsflow -rtsflow
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -iuclc-ixon -ixany -ixoff
-isig -icanon min = 4 time = 0 -xcase -echo -echoe -echok -echonl -noflsh -iexten -tostop -xclude -opost -olcuc -onlcr -ocrnl -onocr -onlret -ofill -ofdel
-isscancode
-autoe -ed_emacs -ed_vi -ed_history
#


Message was edited by: davester
answered Apr 11, 2004 by davester New to the Community (6 points)
0 votes
Yes, with a fully pinned (10-wire minimum) cable, you should at least see DSR asserted. However, the connection problem is related to DCD. The DCD needs to be asserted from your modem, please confirm your cabling integrity and that the modem is configured to assert DCD (carrier) normally.
answered Apr 12, 2004 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
The modem port needs to be open for DTR/RTS to be asserted. When you did the ditty -a, it opened the port momentarily to read the settings, so the fact those signals are asserted in the output is a bit misleading.

When you set S0=2 and the modem didn't answer, were you still in your cu session at that time? If not, was the ttyB25 port enabled to run getty on it? Either cu or getty should have asserted DTR/RTS, and allowed the modem to answer. If you did have the port open from either of those applications (verify a service is running on the port with fuser /dev/ttyB25), and DTR still was not asserted, this might indicate a cabling issue. I don't see any problem with your ditty -a output, other than the fact that absolutely no flow control is enabled (you'd want to turn on rtspace ctspace more than likely), and modems typically use RTS/CTS flow control by default.
answered Apr 12, 2004 by michaelt Veteran of the Digi Community (772 points)
0 votes
I actually connected the modem to a DOS machine to ATS0=2, (simpler). Then i connected it to the Port Server and as mentioned, it would not answet (DTR light on modem was off). I reconnected it to the DOS machine and as soon as i plugged it in, the modem's DTR light went on and it answered (did it while the line was still ringing).

fuser /dev/ttyB25
/dev/ttyB25: 555

As far as cabling being the problem, it cannot be for the following 2 reasons....

A: I'm using the same cable that previously worked with the Accelleport - I swapped directly over to the Port Server , same cable, etc...

B: I've tried using the factory DIGI RJ45 10 wire cable that came with the Port Server (connecting to ttyB14 directly on the port server) and enabling that port, and I get the exact same issue, NO DTR light.

When i arrow through the settings on the PortServer itself, and arrow to 25 (or 14 when using other cable)... The only two lights on are RTS and DTR. I'm not sure if this is reading that the modem is Ready to Send, with Data Terminal REady, or the port on the port server is Ready to send, with data terminal ready.

Please help
many thanks in advance
Davester
answered Apr 16, 2004 by davester New to the Community (6 points)
0 votes
I believe this issue is going to require more indepth troubleshooting than is possible on this board. Best bet to get this resolved would be to call Technical Support and open a case.
answered Apr 19, 2004 by michaelt Veteran of the Digi Community (772 points)
...