Home/Support/Support Forum/Digi Acceleport 2r 920 (rev 01) and Fedora Core 5
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Digi Acceleport 2r 920 (rev 01) and Fedora Core 5

0 votes
lspci shows:

01:05.0 Communication controller: Digi International AccelePort 2r 920 (rev 01)

Followed instructions as per Relnotes.txt but I get the following error:

make[1]: Entering directory `/usr/src/redhat/BUILD/dgap-1.3/driver'
make -C /lib/modules/2.6.15-1.2054_FC5/build SUBDIRS=$PWD modules MYPWD=/usr/src/redhat/BUILD/dgap-1.3/driver
make[2]: Entering directory `/usr/src/kernels/2.6.15-1.2054_FC5-i686'
CC [M] /usr/src/redhat/BUILD/dgap-1.3/driver/dgap_driver.o
CC [M] /usr/src/redhat/BUILD/dgap-1.3/driver/dgap_fep5.o
/usr/src/redhat/BUILD/dgap-1.3/driver/dgap_fep5.c: In function 'dgap_event':
/usr/src/redhat/BUILD/dgap-1.3/driver/dgap_fep5.c:1781: error: 'struct tty_struct' has no member named 'flip'
/usr/src/redhat/BUILD/dgap-1.3/driver/dgap_fep5.c:1782: error: 'struct tty_struct' has no member named 'flip'
/usr/src/redhat/BUILD/dgap-1.3/driver/dgap_fep5.c:1783: error: 'struct tty_struct' has no member named 'flip'
make[3]: *** [/usr/src/redhat/BUILD/dgap-1.3/driver/dgap_fep5.o] Error 1
make[2]: *** [_module_/usr/src/redhat/BUILD/dgap-1.3/driver] Error 2
make[2]: Leaving directory `/usr/src/kernels/2.6.15-1.2054_FC5-i686'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/dgap-1.3/driver'
make: *** [build] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.85834 (%build)

I get exactly the same error whether I use ./configure DISTRO=FEDORA or rpmbuild using the DISTRO line.

I am using the latest drivers from the website (40002347_c.src.rpm) and I believe I have the correct kernel source (kernel-2.6.15-1.2054_FC5.src.rpm = uname -r 2.6.15-1.2054_FC5)

Any help would be much appreciated.

Thanks in advance.
asked May 23, 2007 in Serial Cards by hulbs9nw New to the Community (2 points)

Please log in or register to answer this question.

4 Answers

0 votes
You will want to try the pre-release driver at:

ftp://ftp1.digi.com/support/beta/linux/dgap/dgap-1.3-12.src.rpm
answered May 23, 2007 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
Thank you for the reply. Using this pre-release I get exactly the same error.
answered May 23, 2007 by hulbs9nw New to the Community (2 points)
0 votes
Try using the pre-release driver with the following installation flags:

rpmbuild --rebuild --define DISTRO=FEDORA --define NEW_TTY_BUFFERING=yes dgap-1.3-12.src.rpm

If this does not work, I suggest sending a full log of the installation errors to Digi Tech. Support.
answered May 23, 2007 by userid0 Veteran of the Digi Community (2,158 points)
0 votes
Thanks again but still no joy i'll try tech support.
answered May 23, 2007 by hulbs9nw New to the Community (2 points)
...