Home/Support/Support Forum/Error installing epca driver on Solaris 10
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Error installing epca driver on Solaris 10

0 votes
I am having trouble getting the driver installed for my customer's AccelePort C/X PCI card. When I run setup, all goes well until the following error:

pkgadd: ERROR: The package <epca> has <SUNW_PKG_ALLZONES> = true and <SUNW_PKG_THISZONE> = true: the package may set either parameter to true, but may not set both parameters to true. NOTE: if the package contains a request script, it is treated as though it has <SUNW_PKG_THISZONE> = true
pkgadd:

ERROR: package <epca> cannot be installed on this system/zone

1 package was not processed!

I am using the driver that came with the card, 40001794_J.bin, and I also tried downloading it with the same result.

I did try changing the line inside the script where it sets <SUNW_PKG_ALLZONES>=true, but then pkgadd freaks out and I get cpio errors.

The machine is a SunFire V240 with a basically default install, only the Global zone, and no non-oem software.

Any suggestions?
asked May 10, 2007 in Serial Cards by toganet New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
I'd recommend trying our pre-release ver. 2.0 epca driver for Solaris. You can find it here:

ftp://ftp1.digi.com/support/beta/solaris/epca_2.0.0.pkg
answered May 10, 2007 by michaelt Veteran of the Digi Community (768 points)
...