Home/Support/Support Forum/ANYwhereUSB issues on VMware ESX - Windows 2003 Ent.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

ANYwhereUSB issues on VMware ESX - Windows 2003 Ent.

0 votes
I have been testing this device from multiple WinXP desktops without issues and I have now ventured into testing the device on VMware for it's planned usage throughout our business.

I have tried installing the 1.80 version install and it is not auto detecting the usb ports / installing the drivers.

I have copied the usbd.sys file from the original W2K3 Ent install on hardware as per below though it is still not installing the usb ports.
AnywhereUSB Installation on a VMWare ESX Server

The AnywhereUSB drivers do not install on a VMWare ESX Server

VMware ESX does not support USB. The USB drivers are not copied to the VMware system by default. The AnywhereUSB device is dependent on the USB core files to properly install.

Copy over the usbd.sys file from the original operating system disk into Windows (or winnt) \system32\drivers directory. Reboot your machine.

I can connect to the device from the virtual server and I have tried pointing the "Driver search" to the original install files as well as /windows/system32/drivers and it still will not autodetect the actual ports.

Any clues guys?

Message was edited by: Kendal
asked Oct 31, 2006 in USB Serial by Kendal New to the Community (2 points)

Please log in or register to answer this question.

3 Answers

0 votes
Hello Kendal,

First, make sure to disconnect the XP desktops from the AnywhereUSB via the AnywhereUSB Configuration Utility. To do this, either click the Disconnect button (if available) or click "Edit / Connection List" and remove all IP addresses (if you are done testing on those XP desktops). This will make sure the AnywhereUSB is available for a connection, as one computer (physical or virtual) can connect to it at a time.

On the VMware virtual machine, also remove all entries from the Connection List, then you should be able to click the Connect button (presuming the AnywhereUSB is "discovered" on the left-hand side of the Configuration Utility.). You must choose "Install the software automatically" on each of the 5 found new hardware wizards - do not choose "Install from a list or specific location".
answered Oct 31, 2006 by jeremym Veteran of the Digi Community (1,687 points)
0 votes
Had already made sure that the xp clients were disconnected.

The install and connection to the actual device is fine...

It is the actual process that windows go through detecting the actual usb.

It detects the first USB and then looks for the driver and just sits there waiting as it is searching for it.

It did the same thing when trying to install on W2K until I copied over the file usbd.sys from a existing W2K (physical) server.

I then tried the same fix for W2K3 and it allows me to connect to the device fine on install of the 1.80 ver software and then when connecting to the AnywhereUSB device it proceeds with USB detection.

That is where is will not find the drivers.
W2K3 Enterprise - Service pack 1 - copied the usbd.sys file from a physical server

Message was edited by: Kendal
answered Oct 31, 2006 by Kendal New to the Community (2 points)
0 votes

It is all now installed and detected on W2K3 Enterprise.

(Thanks Jeremy)

Just for the information of anyone else planning to use this on the above operating system be aware that the actual USB device detect takes over 10 mintues per usb port on the device. This equates to a total of 50 mintues to detect the usb ports.

I obviously wasn't patient enough as it would run for around 5-8 minutes sitting there in detection mode when i'd give up on the process.
This is strange considering on XP/W2K servers it took 1-3 seconds a port to sort itself out.

Not sure what the issue is in regards to it taking over 10 minutes a usb port but hopefully it is just a W2K3 detection issue and will not impact anywhere else....

answered Nov 1, 2006 by Kendal New to the Community (2 points)