Home/Support/Support Forum/USB Keyboard
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

USB Keyboard

0 votes
I purchased a Microsoft Comfort Keyboard to use with the ConnectPort. I am connecting it to the front USB port with no success. When the keyboard is connected directly to the computer it works fine. For some reason it does not seem to be getting the power from the port though. I also have a USB mouse and it works just fine from both ports. Any suggestions?

Steve
asked Jul 23, 2007 in ConnectPort Display by smnavarre New to the Community (3 points)

Please log in or register to answer this question.

5 Answers

0 votes
Hello,

Try using a standard US-101 USB keyboard, as they are recommended as being the most compatible by our Engineering group.
answered Jul 23, 2007 by jeremym Veteran of the Digi Community (1,687 points)
0 votes
I went and purchased a very basic keyboard with a USB connector and it still didn't work. What I did do was update the firmware with the update you sent me and the keyboards started working just fine.

Steve
answered Jul 24, 2007 by smnavarre New to the Community (3 points)
0 votes
Steve,

Thanks for the update!

If you recall what firmware version you were running, when the USB keyboards weren't working, please let me know. Also let me know what firmware version you are now running, where they started working.
answered Jul 24, 2007 by jeremym Veteran of the Digi Community (1,687 points)
0 votes
The firmware was the original that shipped with the unit...2.1.0.0 (Version 82001062_A 12/09/2005), upgraded to firmware version: 2.3.2.3 (Version 82001062_B_SA2 03/28/2006)

Steve
answered Jul 24, 2007 by smnavarre New to the Community (3 points)
0 votes
I had the opposite problem with a Dell mouse, switched mouse with another dell optical and it worked fine, dell keyboard works also.
answered Oct 1, 2007 by wakers9 New to the Community (2 points)
...