Home/Support/Support Forum/Upgrading the IDBlock
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Upgrading the IDBlock

0 votes
It's been over a year since I was actively using the rabbit boards here, but one of our rabbit projects was pulled off the back burner here and I needed to get my development environment back up. I ran into an issue however, these old BL2500's are acting like they have no ID block when using 9.52.

I recall shortly before I the project was backburnered that 9.2x changed how the ID blocks are stored. I can't seem to find any information on updating from the old to the new ID blocks. Any idea where the utility for repairing the ID blocks would be on this?

The error I'm getting is...

"WARNING ERROR: No parameters found for flash id received from pilot bios - using default parameters."
"WARNING BOARDTYPES.LIB: No ID Block found on the target; defining _BOARD_TYPE_ to be a BL1810."
And some assorted things due to no board type being set.
asked May 30, 2007 in Rabbit by Kazriko New to the Community (6 points)

Please log in or register to answer this question.

2 Answers

0 votes
BTW, for reference, the board works perfectly in DynamicC 9.01, but I need the Modbus/TCP module that needs a newer version of DynamicC.
answered May 30, 2007 by Kazriko New to the Community (6 points)
0 votes
Solved it. It appears that project files are not compatible across versions and will fail silently on you, causing all kinds of erratic problems.
answered May 30, 2007 by Kazriko New to the Community (6 points)
...