Home/Support/Support Forum/Unrecognized NAND Flash device.
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Unrecognized NAND Flash device.

0 votes
Hi! I have a problem with i.MX51 and NAND FLash device.

After do one UBOOT update we received:


NVRAM: Original Flash is BAD
NVRAM: Mirror Flash is BAD
NVRAM: Original Flash and Mirror Flash don't match
NVRAM: Original and Mirror don't match
NVRAM: Original and Mirror Flash don't match
NVRAM: No NVRAM contents usable
NVRAM: Resetting Workcopy
NVRAM: Repairing Original
NVRAM: Resetting Workcopy
NVRAM: Using defaults
*** Warning - bad CRC or NAND, using default environment

NVRAM: Using defaults


U-Boot 2009.08 - dub-1.1.3 - (sep 24 2012 - 09:26:38) - GCC 4.4.3
for ConnectCore i.MX51 on a JumpStart Kit Development Board

I2C: ready
NAND: 256 MB
DRAM: 256 MB
MMC: FSL_ESDHC: 0, FSL_ESDHC: 1
In: serial
Out: serial
Err: serial
Net: FEC0 [PRIME]
Autoscript from TFTP... [not available]
CCMX51 #

.....

CCMX51 # flpart
Nr | Name | Start | Size | Type | FS | Flags
0 | U-Boot | 0 | 768 KiB | U-Boot | | fixed
1 | NVRAM | 768 KiB | 512 KiB | NVRAM | | fixed
Commands:
a) Append partition
d) Delete partition
m) Modify partition
p) Print partition table
r) Reset partition table
q) Quit
Cmd (? for help)> r
OS Types:
n) None
l) Linux
a) Android
w) WinCE
o) NET+OS
OS (? for help)> l
Partition table reset
Nr | Name | Start | Size | Type | FS | Flags
0 | U-Boot | 0 | 768 KiB | U-Boot | | fixed
1 | NVRAM | 768 KiB | 512 KiB | NVRAM | | fixed
2 | Splash | 1280 KiB | 1 MiB | Splash-Screen | |
3 | Kernel | 2304 KiB | 3 MiB | Linux/Android-Kernel | |
4 | RootFS | 5376 KiB | 64 MiB | Filesystem | JFFS2 | rootfs
5 | Rescue-Kernel | 70912 KiB | 3 MiB | Rescue-Linux/Android-Kernel | |
6 | Rescue-RootFS | 73984 KiB | 32 MiB | Rescue-Filesystem | JFFS2 | rootfs
7 | UserFS | 106752 KiB | 155392 KiB | Filesystem | JFFS2 |
Cmd (? for help)> q
Partition table has been modified. Save? (y): y
Writing Parameters to NVRAM
*** Error: NVE_NO_SPACE: ()
CCMX51 #
asked Dec 10, 2012 in Windows CE by ztiakra New to the Community (0 points)
recategorized Sep 20, 2013 by tuxembb

Please log in or register to answer this question.

1 Answer

0 votes
Hello, Are you using Wi-i.MX51(wireless module) or i.MX51(Non wireless module) module? Choose correct default u-boot image from your pc.

You can find wireless and non wireless uboot images under below paths

Wireless module's U-Boot image:
C:\Program Files\Digi\Windows embedded compact 7\Images\ConnectCore Wi-i.MX51\JSK\bootloader

Non wireless module's U-Boot image:
C:\Program Files\Digi\Windows embedded compact 7\Images\ConnectCore i.MX51\JSK\bootloader
answered Jan 23, 2013 by cpigilam Veteran of the Digi Community (655 points)
...