Home/Support/Support Forum/USB device not recognized

USB device not recognized

+1 vote

I got a proper connection to the interface board first time I tried. However, today I get an "USB device not recognized" error when trying to connect, so I can't communicate with the xbee wifi at all. I got the same error when trying to connect to the previously unused interface board as well.

I'm using windows 7 professional. Do you have any experience with this issue and can you advice me how to resolve it?

asked May 8, 2012 in IEEE 802.11 (Wi-Fi) by dolberdinho New to the Community (1 point)

Please log in or register to answer this question.

6 Answers

+1 vote
The device can easily 'move' ports between computer reboots and/or moving the board to a different USb port. So perhaps yesterday it was COM6, but today it might be COM11.

Various power issues might also crop up, for example I have a 4-port USb hub which for some reason won't power things on the second port (I guess it's "burned out").
answered May 9, 2012 by lynnl Veteran of the Digi Community (1,047 points)
0 votes

Is the interface board a Digi's original? .

that is
answered May 9, 2012 by chobichan Community Contributor (100 points)
0 votes
Did you try updating your motherboard drivers?
in the device manager click on view at the top and in the dropdown
show hidden devices
answered May 11, 2012 by david24 New to the Community (1 point)
0 votes
Thanks @david :)
answered May 11, 2012 by jocnouinfo New to the Community (1 point)
0 votes
From http://ftp1.digi.com/support/documentation/ErrataStatement150320_v2_XBeeDevKitv_Final.pdf

"Some Digi XBee® development board kits were confirmed to exhibit an inability to enumerate when powered solely from a PC via the USB port. The cause for failure was found to be on the development board (see below Table 1 for affected board versions) where a small variation on the voltage regulator causes some USB circuits to not function properly. This issue can be resolved reliably by using the external power supply supplied in most of the kits. See the resolution detail below for more information. Once a product initially enumerates the product should continue to operate to specification."

See also http://ftp1.digi.com/support/documentation/ErrataStatement150320_XBeeDevKitv_Final.pdf
answered Jan 7, 2016 by testkins New to the Community (6 points)
0 votes
Hello, I am continuously getting this error. USB Device Not Recognized
I went through many sites, on microsoft, hows.tech, wikihow and many. Did not help.

My USB device is not getting detected.

Let me explain in detail :

I have a connection problem. I have a Nokia N80 and use Windows 10. This is the first time I have encountered a problem with PC Suite, because it worked yesterday but my device was not recognized by the PC for 2 days. I'm not sure what happened and I tried almost everything but it still didn't work. I deleted all Nokia software and even cleaned the registry, instead of installing PC Suite again but the same problem still occurred. If this helps, I use the version of PC Suite 6.82 that I downloaded yesterday.

Do I need to install any kind of hotfix mentioned in this guide Method 2

answered May 22, 2019 by pradeep_gupta New to the Community (5 points)