Home/Support/Support Forum/Trouble getting started with CANbus development
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Trouble getting started with CANbus development

0 votes
ConnectCore Wi-i.MX53 on JSK development board
Digi SDK 3.4.2
Win CE 7.0.2817.0

I am trying to determine what the can.dll exposes so I make the calls from managed code. I notice that export definition file refers to the canbus library and exposes the stream interface calls from can_io but there is no canbus.dll file. The CanApp application is somewhat useless because it's calling canbus directly and I really only see it as a proof of concept. What is the best way to access the can functionality for robust coms including rx masking and other can bells and whistles that are hinted at in the drivers?

Also, using the CANApp program, I'm noticing that each 4-byte segment of an eight byte message is being reversed before being sent out (or reversed when read). Example; send 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08 to a node and the node reads 0x04, 0x03, 0x02, 0x01, 0x08, 0x07, 0x06, 0x05. When reading the sequential buffer, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08 from the node becomes 0x04, 0x03, 0x02, 0x01, 0x08, 0x07, 0x06, 0x05. Is this normal behavior?? I wasn't expecting any endian problems between devices.
asked Oct 24, 2012 in Windows CE by skezix New to the Community (0 points)
recategorized Jun 17, 2013 by mcarver

Please log in or register to answer this question.

...