Home/Support/Support Forum/Xbee pro must be reset to have anything work and communication is iffy.

Xbee pro must be reset to have anything work and communication is iffy.

0 votes
Hardware: (2) Xbee-pro 900 version 1061
XBee Explorer USB ;connected to computer (sparkfun)
Xbee Explorer Regulated; connected to device (sparkfun)

Background: I have forced my usb to give 250mA to make sure i have sufficient power.

When trying to connect to X-CTU software the modem (xbee) is not recognized until i reset the device. I have tried many solutions to fix this that have been posted to this forum. I have restored defaults and all writing of the firmware is passed but when i reconnect the modem it does not get recognized until i reset again. this is on both modems. baud rates are correct

I gave up on doing the same thing over and over trying to fix the issue. so i went to terminal to test and when i send
"+++" it returns"OK." or sometimes"O.." never just "OK" when i give the command for it to find other devices "atnd" it returns gibberish(different gibberish every time). I have a photo of this but don't see a way to post this.

When doing a rang test my device shows that Tx and Rx have activity. showing me that it is sending and receiving. my device modem has the Dout and Din shorted.

I have tried almost everything short of throwing in the trash and hopefully whatever great solution this community has for me.
asked Jul 15, 2013 in Multipoint Proprietary by Acadian New to the Community (0 points)
edited Jul 12, 2013 by Acadian

Please log in or register to answer this question.

3 Answers

0 votes
I think reflashing the firmware will help.
Try the below links, http://todigi.blogspot.in/2010/05/xbee-obituaries-xbee-returns-from-grave.html
http://www.jsjf.demon.co.uk/xbee/faq.pdf (Q12)
answered Sep 28, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
0 votes
Acadian Hello , I had the same problem with the XBee , however was a track XBee Explorer Regulated there was only 2.95 volts to pin 1 of the module . Soldered a wire direct and resolved .
answered Oct 15, 2013 by jrosivan New to the Community (3 points)
0 votes
Did you find a solution to this by any chance?

I am having exactly the same issue.

Tried various explorer boards or direct TTL.

Running Pro 900HP 200k (XBP9B-DM) on firmware 806A
I also tried the latest firmware, but this one was always reliable.

One XBee works perfect, the other needs to be reset at every stage of reading or writing FW or settings.
answered Aug 14, 2014 by Ockert New to the Community (1 point)