Home/Support/Support Forum/Having problem updating XCTU ver. 5.2.8.6 installer on window 7

Having problem updating XCTU ver. 5.2.8.6 installer on window 7

0 votes
When installing XCTU, i was asked if i would like to update the XCTU (recommended). After pressing yes, there is an error coming out saying Microsoft Visual C++ problem, then installation failed.

If i press No to update, when i connect my Xbee to my laptop, i couldn't Read it, when i press the read button, i was ask to update, then it shows an invalid argument was encountered.
asked Jul 17, 2013 in XBee Programmable Development by Wimpylicious New to the Community (0 points)

Please log in or register to answer this question.

3 Answers

0 votes
Hi,

Did you download X-CTU from the following link, http://ftp1.digi.com/support/utilities/40003002_C.exe ?
(Run as Administrator).
I m also using Windows 7 and it works for me.
Unistall and install again and see it it works.
answered Jul 18, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
http://s262.photobucket.com/user/Wimpish/media/Capture.png.html

This picture above is what it shows when i want to update during installing
0 votes
Which version of Windows are you using?
is it 32 bit or 64 bit?
answered Jul 25, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
32 bit, is that the problem?
0 votes
X-CTU supports 32 bit. There is no such problems. I m using 64 bit and x-ctu works well for me.
If possible can you try with different PC?
answered Sep 28, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
...