Home/Support/Support Forum/what to do when xctu indicates unable to connect to com port?

what to do when xctu indicates unable to connect to com port?

0 votes
I am working on xbee pro modules for wireless communication. I purchased the adapter board and a breakout board for that too. previously when I connected my xbee with the adapter it worked fine and I was able to configure it but yesterday when I was reading the parameters the x ctu software indicated unable to.connect to com port. I tried again but the com port could not be detected. I dont know where the problem is. I am new to xbee and all these things. please help me in this regard.
asked Jul 22, 2013 in IEEE 802.15.4 by Maheen New to the Community (0 points)
recategorized Jul 20, 2013 by Maheen
i did the same following this link:
http://www.digi.com/wiki/developer/index.php/Bootloader_to_force_XBee_reflash but xbee did not return any of the thing mentioned here. I tried the other xbee too, the problem remains the same. More over the CTS(line status) was blinking continuously. Actually it was working fine previously, i was in the midst of reading/writing parameters that this error occured. Since then x ctu have not been able to communicate with modem. The problem is why it stopped working when everything was working correctly prevoiusly. I updated the firmware last time it worked correctly. Is this the issue?

Please log in or register to answer this question.

3 Answers

0 votes
Hi,

- If you are using Digi XBIB boards, use the following drivers, http://www.digi.com/support/productdetail?pid=3352&type=drivers
- Also make sure that baud rate and COM port settings are correct under PC Settings in X-CTU
- If the modules is damaged, reflash the firmware on it.
answered Jul 22, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
0 votes
When this kind of errors appears make sure that the Baud rate and COM port settings are correct under PC settings in X-CTU.
- Can you see the bootloader when you tried the given link, http://www.digi.com/wiki/developer/index.php/Bootloader_to_force_XBee_reflash ?
If No, then contact Digi people, create an Online Support Request at the following link, https://mydigi.secure.force.com/customers/
answered Jul 25, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
0 votes
Recently i noticed one more solution for this. I used Digi interface boards, I'm not sure about other boards.

Try to reflash the firmware using below steps

- Change the baud rate to 38400 and check "No baud change" under PC Settings in X-CTU
- Go to Modem Configuration tab, select correct Modem, Function set and Version
- Click "Show Defaults"
- Check "Always Update Firmware"
- Click "Write"
If "Action Required" window pop up, press the reset button on the interface board once, Digi interface provides reset button.
I'm not sure about other boards. The pop up disappears and module gets programmed to selected firmware.
- If you get any errors, like checksum error failed, you need to optimize your interface boards, refer the following link, http://www.digi.com/support/kbase/kbaseresultdetl?id=3418
- Now go to PC Settings and change the baud rate to 9600 and uncheck "No Baud Change"
- Go to modem configuration tab and select Read, you can see all the XBee parameters.
answered Sep 28, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
...