Home/Support/Support Forum/How do I force S6B into SPI mode?

How do I force S6B into SPI mode?

0 votes
I am trying to force the S6B into SPI mode by driving the DOUT line LOW, driving RESET LOW and then HIGH to reset the device. The manual indicates that doing this should force the device into SPI mode. After RESET goes HIGH I should then see ATTN go low indicating there is a MODEM STATUS frame in the buffer to be read.

I never see the ATTN line go LOW. Any thoughts?

A few other details.

When RESET is asserted LOW the ATTN line is LOW and remains LOW for 15ms after RESET is deasserted.

I can RESET the device and then send an AT command over SPI that is acknowledged with a response, but I can't seem to get the response to the force SPI mode.

I am sing the surface mount module.

Any help would be appreciated.

jkf
asked Jul 25, 2013 in IEEE 802.11 (Wi-Fi) by jkf2 New to the Community (1 point)
Try using a different method(use UART and AT commands for manualy choosing SPI pins as SPI):
After turn power on choose AT commands mode (send "+++")
Waiting for an answer "OK."
Then send following AT commands: ATAP1(i thing that SPI correctly working only in API mode), ATD21, ATD31, ATD41, ATD96, ATP21 and ATCN or ATAC for apply command.

Please log in or register to answer this question.

1 Answer

0 votes
Just as a follow up for those with interest in this issue it appears that the process described in the S6B manual for forcing the unit into SPI mode works for the through hole device, but not the SMT version. Digi Support responds,

"It looks like putting the SMT version in SPI mode with the [DOUT] pin does not disable the UART (P3=0, P4=0.) With the UART active the module discards API messages at boot. I am submiting this to engineering as a possible bug.

Digi Technical Support"

This may work in the future!
answered Jul 29, 2013 by jkf2 New to the Community (1 point)
+1
I have a module XBee S6 and board with a microprocessor.
Okay, I understend. This method does not work correctly! I use a different method (manually reassign the pins of the module to SPI using UART):
After I turn power on i choose mode AT commands (send "+++")
Waiting for an answer "OK."
Then send following AT commands: ATAP1, ATD21, ATD31, ATD41, ATD96, ATP21. All these commands get a reply "OK." for each of the commands. Then the serving command to exiting the AT (ATCN) and get the response "OK."
Immediately after the last response module SPI_nattn pin goes low informing me of the fact that there is data in the buffer SPI. I'm trying to read this data by SPI protocol until the pin goes into the state of the logical 1, but he did not go into this state. SPI still does not work!
What do we do now?
...