Home/Support/Support Forum/How to set a xbee(router) as a repeater between end-point device and coordiantor?

How to set a xbee(router) as a repeater between end-point device and coordiantor?

0 votes
I'm trying to set a xbee to repeating signal between end-point and coordinator. The middle xbee repeater does not need to attach to arduino. Can I do this and how? thanks

ps: I'm using xbee s2
asked Oct 15, 2013 in DigiMesh Proprietary Mesh Networking by xujianningkp New to the Community (0 points)

Please log in or register to answer this question.

4 Answers

0 votes
You mean you want to send data to/from end device and Coordinator with the help of a Router in between them?
answered Oct 15, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
Yes. I want to add the repeater xbee to extend the signal distance between end device and coordinator
0 votes
Have you tried to give to destination address at Endpoint as Router address and Router destination as 0000. It is my Guess. may /may not work. I too new to Xbee. :s
answered Oct 17, 2013 by chandras002 New to the Community (2 points)
0 votes
If you set router destination as 0000, it broadcast packet to all nodes in the network.
I think below settings helps
End device Destination = Router SH and SL
Router destination = Coordinator SH and SL
answered Oct 31, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
Thanks for your answers. Yes I did the way as you said
End device Destination = Router SH and SL
Router destination = Coordinator SH and SL
My plan is to sending the data out from the end device to the coordinator through router/repeater xbee. Can I set two or more routers between End device and coordinator? So, if one router is disconnected from the network, the other router will automatically take care of the data transmitting. Should I change the direction so the data transfer from the coordinator and broadcast to the end device? Will that be easier?
Thank you for your time.
0 votes
Is this working ? I am facing similar issue.

I am trying to make following topology in API mode. End device (E) <--->Router (R) <----> coordinator (C) Is it feasible ? I have configured both xbees in API mode (2). I am not able to see communication happening between end point and router in APi mode. Please help to fix this.

However, following topology is working: Router (R) <---> Coordinator (C)
answered May 12, 2017 by jyot.su New to the Community (1 point)
Hello, I am facing the same situation too. Have you solved it?

Thanks
...