Home/Support/Support Forum/The modem configuration was not found

The modem configuration was not found

0 votes
Hello, everyone

About a year ago, I bought 3 Digi Xbee Pro modules (XBP24-AWI-080-revB 2008-09-28-10), and successfully worked with them through X-CTU. But now I can't do it: when i press "Test / Query" button, it prints:
Communicating with modem..OK Modem firmware version = 10ED Modem type = [b]Name unknown[/b] (ID=242114) Serial Number = ......

And when I try to read Parameters, the program asked for updates, but after a while sad: "Modem configuration file not found"

Then I selected Modem: XBP24, Version: 10EC, and pressed Write (with Always Update Firmware checked)
that failed with:
"Programming modem...Lost communication with modem"
error, and now that module doesn't even answer to "Test / Query"

What can I do with it?

(p.s. Sorry for my English, it's not my native language)
asked Nov 25, 2013 in IEEE 802.15.4 by romix.lab New to the Community (1 point)

Please log in or register to answer this question.

3 Answers

0 votes
Any ideas? I really need that modules working...
Tried xbwfup for linux, no result
It seems that module doesn't return bootloader prompt string "BL >"
answered Nov 29, 2013 by romix.lab New to the Community (1 point)
0 votes

Reflash the firmware with latest firmware version.
If you get error "Modem configuration file not found, then Download the versions from http://www.digi.com/support/supporttype?type=firmware , select your radio type.
Go to X-CTU and click "Download new version" and select "File" as option and select the downloaded file."

Hope this helps.
answered Dec 5, 2013 by 16ksa23 Veteran of the Digi Community (426 points)
I found the right config. But still can't upload firmware, even the same one... (Now I got message about difference in baud rates)
0 votes
Check your COM port settings under PC Settings. Try with different baud rates like 38400,115200 etc
answered Jan 7, 2014 by 16ksa23 Veteran of the Digi Community (426 points)