Home/Support/Support Forum/Communication error dinamic c Rcm5600w
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Communication error dinamic c Rcm5600w

0 votes
Hi, ive got a RCM5600W Kit and i tried to compile a sample project but it takes the text: communication error.
Ive got Dinamic C 10.67 and windows 7, i downloaded the last driver for USB but nothing happens.

Please i need help!
asked Dec 17, 2013 in USB Serial by Ferpetro7 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Good morning,

If you are using the USB cable, there may be an issue with the latency timer on your pc port.

you might want to adjust the latency timer on the port you are using:



If you are having communications issue, you may need to adjust the latency timer on your port: (if you are using the USB programming cable)

There is really slow performance on some test fixture’s FTDI USB-to-serial COM ports, we discovered that in the USB COM port’s “Advanced Settings” dialog box there is a “Latency Timer (msec)” selection drop-list. We found that reducing the latency setting from the (apparent) default of 16 msec to a much smaller value (1) resulted in much better performance.

Set 1 msec latency on the COM port I used with DC 9.62. I haven’t had a DC 9.62 target communication error on that COM port since.

The FTDI USB-to-serial COM port “Advanced Settings” dialog box looks like this on my PC:



Notice in the “BM Options” area the “Latency Timer” selection drop-list.

I think the latency setting of 1 msec might be using up more CPU and / or USB bandwidth than necessary, so it might be best to experiment a little and use the highest latency setting that doesn’t cause frequent TC errors.
answered Dec 17, 2013 by MargaretK Veteran of the Digi Community (545 points)
Hi Margaret, ive already done that, but there is still the problem, the communication error is:

While sending Pilot BIOS:
Timeout while waiting for response from target.

Ive tried everything in two different computers but its always the same.
...