Home/Support/Support Forum/ConnectPort X2D and XCTU using RFC 2217 (without RealPort)
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

ConnectPort X2D and XCTU using RFC 2217 (without RealPort)

0 votes
Hi all,

I'm having problems connecting to a ConnectPort X2 directly from XCTU, using the RFC 2217 (without RealPort)

I've followed the following steps:

1.- Change the ConnectPort X2 configuration:

Configuration -> XBee Network -> Gateway Access -> Enable serial access to the gateway radio
Configuration -> Serial Ports->Port 1-> Change profile -> TCP Sockets

2.- Install A COM Port Redirector http://en.wikipedia.org/wiki/COM_port_redirector. I'm trying with http://www.tacticalsoftware.com/virtual-serial-port-redirector/serial-ip.htm

3.- Try to connect the Zigbee Radio using XCTU.

Any ideas?
Thanks in advance
asked Apr 3, 2014 in Digi Connect Cellular by Borja New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
When you setup your comm port redirector, I'm assuming you need to plug in the IP address of your CP-X2D, as well as a TCP port number. What port are you telling the program to use? What baud rate and attributes are you selecting in XCTU, namely is the "Enable API" box checked, and are you setting the baud at 115,200?
answered May 8, 2014 by michaelt Veteran of the Digi Community (749 points)
Hi and thanks for your reply Michaelt,  After re-loading the firmware of the zigbee coordinator I'm reading data without any problem using both RFC 2217 or the RealPort driver. I've to do this for every ConnectPort but it's a solution.

Note: If you reset ConnectPort to factory default you need to re-load firmware to radio again.
Yes, on the CP-X2D at factory default, Direct Access would be an option, but Python would be the default mode of operation for the Gateway.  I'm glad to hear you got it figured out.
Contact a Digi expert and get started today! Contact Us