Home/Support/Support Forum/xbee_device_manager doesn't like the module_id of 1
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

xbee_device_manager doesn't like the module_id of 1

0 votes
Hey all. My CPX4 802.15.4 has a dd=10002. Are these supported by Dia?

xbee_device_manager throws me the following
Code:
DEBUG:XBeeDDOParamCache:CACHE STORE: cached 'DD' = '\x00\x01\x00\x02' for 'None' CRITICAL:xbee_device_manager:This xbee manager cannot use the xbee mod ule on the gateway. (Maybe there is a digimesh/zigbee mismatch?) Exception in thread xbee_device_manager: Traceback (most recent call last): File "./threading.py", line 442, in __bootstrap File "C:\Users\D12-109\workspace\Oman\src\devices\xbee\xbee_device_m anager\xbee_device_manager.py", line 677, in run File "C:\Users\D12-109\workspace\Oman\src\devices\xbee\xbee_device_m anager\zigbee_device_manager.py", line 204, in validate_network_protoc ol ZigBeeDeviceManagerUnsupportedModuleType: module_id: 1, accepted modul e ids: (3, 10, 0)


Digi ESP for Python Version: 2.2.0

Thanks
asked Apr 29, 2014 in Python by chaser New to the Community (0 points)
retagged Apr 30, 2014 by chaser

Please log in or register to answer this question.

1 Answer

0 votes
I would recommend looking for DD value at http://www.digi.com/wiki/developer/index.php/Python_Wiki. You should be able to find what you are looking for.
answered Apr 30, 2014 by mvut Veteran of the Digi Community (11,302 points)
according to the DD it's an 802.15.4 Connect port X4, which is correct. I went back to Dia 1.14 and it works fine. I'm guessing they dropped support for 802.15.4 in 2 but I saw no mention in the change logs.
...