Home/Support/Support Forum/XBEE Sleep mode (Sampling on Wakeup)

XBEE Sleep mode (Sampling on Wakeup)

0 votes
Hello There, I have configured my XBEE Series 1 in Sleep mode , but when i send it a low signal on pin 9 to wake it up... it starts sending samples each 5 seconds as long as the module is awake.

so could any one please tell me how to disable this sampling, as i wanted the radio to send me only one time when the module wakes up ?
asked May 21, 2014 in IEEE 802.15.4 by Digi_Fan New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

0 votes
Sounds like you are using Pin sleep. Try using Cyclic sleep instead and setting your time before sleep for 20ms. Then set your IT to 1 and your IR to 15 (0x0F).
answered May 21, 2014 by mvut Veteran of the Digi Community (12,756 points)
Thanks mvut for your reply,
yes am using pin sleep (SM='1')"Pin hibernate" because it is strongly recommended for my project to use this mode. so is it possible to diable this sampling in the pin hibernate mode ?
Try changing IT or IR.
am setting both to zero, is that right?
If you want to disable ADC samples that would be correct.
sorry for bothering you, but nothing changes ... the remote radio still sending me samples each 5 seconds as long as it is awake !.
For more explanation, my hardware is connected as follows:
the remote radio is set to be in sleep mode (SM=1),
pin 9 is asserted to the Vcc in order to maintain the remote radio in sleep mode.
when an external trigger occurs on pin 9 to de-assert it (low) ,it wakes up and starts to send those samples to the base radio each 5 seconds.
sorry but i am really confused !
Are any of the ADC lines enabled?
no, they are all disabled
What function set and firmware version is installed on your modules?
XBEE modem ---> XBP24
Function Set --> XBEE PRO 802.15.4
Version --> 10E6
Then either you are issuing a remote IS command or you have a sample rate enabled on the module with the matching 64 bit address that is in the API frame.
...