Home/Support/Support Forum/NO command reverts to "3" even if I write 2

NO command reverts to "3" even if I write 2

0 votes
I'm using a mesh network of 1 coordinator (21A7), a few routers (23A7), and some end devices (29A7). I'm in API mode for communicating to the radios in the field.

When I issued an API mode ND command, there was no response from my field Xbees. I checked channels, and it seems the C and EDs were on 2 different channels (they were powered down briefly). The radios responded and got on the right channel after changing the NO value to 2. But it doesn't stick.

Qs:

1) I'm not too clear on the "NO" setting of 3 as described in the manual. Does it also enable an ND response frame?

2) Using XCTU, I changed "NO" to 2 on the coordinator, wrote it, closed the connection, reopened it, read parameters, and it had again reverted to 3. Can you clarify it this effects the API ND command in some way?

BTW, I just downloaded the new XCTU and have been using it on both Mac and Windows. Thank you for this, it has made life so much nicer!
asked Jul 27, 2014 in ZigBee PRO Featureset (and legacy ZNet 2.5) by carollaf New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
All it does it appends the Node Discovery response frame to include the DD value or not. It also tells the node to report its self or not if a ND is issued.
answered Aug 18, 2014 by mvut Veteran of the Digi Community (11,302 points)
...