Home/Support/Support Forum/Xbee s1 sleeping with digital line passing

Xbee s1 sleeping with digital line passing

0 votes
My digital line passing works with 2 s1 xbees but once I set sm =1 the line passing functionality stops working. I tried different combinations setting pin 9 high/low and cts (Pin 12 I believe) high/low. I read in the manual cts needs to be set 2byte cycles prior to pin 9 set to ground. Can anybody explain how cts is involved and what I'm doing wrong. I've set sm back to 0 and the digital line passing works again.

Thanks in advance!
asked Jul 31, 2014 in RF Solutions and XBee by iiimif New to the Community (1 point)
edited Aug 1, 2014 by iiimif

Please log in or register to answer this question.

3 Answers

0 votes
Are you setting both modules to sleep mode or just one? If just one, is it the input or the output that is sleeping?
answered Aug 1, 2014 by mvut Veteran of the Digi Community (11,302 points)
0 votes
I Set the sender to sleep unless the digital in is turned on because it'll be running remotely on batteries. Receiver is not set in sleeping mode as it will be running off a power source and turning on a relay.
answered Aug 4, 2014 by iiimif New to the Community (1 point)
0 votes
When using DIO line passing, hardware flow control is not used.

Can you be more specific as to what it is you are observing?
answered Aug 4, 2014 by mvut Veteran of the Digi Community (11,302 points)
...