Home/Support/Support Forum/Custom PCB for Wi-i.MX53
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Custom PCB for Wi-i.MX53

0 votes
I am working on a project where I am designing a custom PCB for the Wi-i.MX53 module, and am having issues getting the module to boot. I have so far copied the boot selection logic circuit, and the power on circuit. But when the board boots nothing happens on the UART0(Console) pins, I have broken these out to a pin header for ttl access. I can see that the power draw increases when I press the power button on my board, so I assume this part works. I have also put a connector for the parallel display interface, but this yields no results either. The module boots fine in a Jumpstart kit board, with output on both the console UART and the display interface.. is there any tricks or appnotes regarding this?
asked Aug 29, 2014 in Embedded Devices by slm New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
can you check if 3.3v is generated on the module?
Here iss a typical scenario for the power-up sequence of ccwimx53. Highlighted is what gets 3.3v generated.
- Power On power supply
o VCHRG generated on the board. This is the main supply for the CCWMX53 module.
- The PMIC generates the module supplies.
o The +2.775V supply is generated at this point
- The CPU is powered and it check the bootstrap to start boot process
- UBoot sets the PWR_EN signal to enable the external regulators
o The +3.3V supply is generated at this point
- The +3.3V and +5V regulators are enabled and the base board is powered
answered Sep 2, 2014 by LeonidM Veteran of the Digi Community (3,028 points)
...