Home/Support/Support Forum/Allow wired client to use digi transport's wifi
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Allow wired client to use digi transport's wifi

0 votes
I'm having a hard time figuring out how to allow a computer hard wired to the digi transport router to use the digi's active wifi connection.

The digi can ping out. Its wifi connection is up.
Current setup is:
1.Computer plugs into lan0 on the digi.
2. Wifi is connected in client mode to my wifi connection and I can ping from the digi to 8.8.8.8.
3. I'm user logical eth12 as the interface for wifi.

The computer behind the digi cannot pull an address via dhcp and if I set the address, it can't resolve anything.

I'm sure it's something simple I'm missing. Can anyone help?
asked Sep 10, 2014 in Digi TransPort Cellular by bryan New to the Community (1 point)

Please log in or register to answer this question.

3 Answers

0 votes
Put your "config c show" or your "type debug.txt" here or on pastebin.

Obviously take out any identifiable information.
answered Sep 11, 2014 by NicholasWilson Veteran of the Digi Community (1,003 points)
0 votes
Sorry, for the delay. I had to tell the interface to go OOS after 1 second. This allowed the next default route to take over. Hope that helps someone in the future.
answered Sep 18, 2014 by bryan New to the Community (1 point)
0 votes
Hi Bryan,

I also having a problem maybe you can help me. I have a WR41 with one ethernet port. I have set up logical eth 1 to get DHCP from our vessels WiFi:

192.168.120.130
255.255.255.0
192.168.120.1
DNS 192.168.120.22

I can ping out to google and 8.8.8.8 from the Digi, with WiFi 0 linked to Eth1.

So now to match this logical eth1 to physical eth0 and get the internet on my laptop - or so I keep trying.

I have put my laptop in static ip address within the same parameters as above and also had the digi allocate it DCHP within teh same parameters, but I can't seem to ping past eth0 from teh laptop. I thought Eth0 and Eth1 should somehow be linked. The manual mentions 'Hub' mode but only for more than 1 physical port.

Whenever I try and bypass logical Eth1 and link the WiFi with Eth0 then suddenly I loose teh web interface, can't scan the digi on any ip address and have to power cycle.

The QN's are missing parts and not helping totally. Do I have this Advanced option 'enable bridge on this interface' ticked? If so on eth0, eth1 or both? And Bridge instance what, 0, 1?!

Hope someone can help.

Cheers
answered Apr 5, 2015 by EOSETO New to the Community (1 point)
if you can get a IP from the transport on eth0 and eth1 is in a diffrent range you might have to enable nat on eth1 and also set a default route to use eth 1

check the routeing table in GUI or route print and makr sure the active default route is eth 1 or it by default will try to send all trafic out of PPP 1
...