Home/Support/Support Forum/How to run the ntpd as a server
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How to run the ntpd as a server

0 votes
have configured the project to include the ntpd and during system startup I see the console message "Starting ntpd: OK" but when trying to sync from an ntp client I get no response. If I logon to telnet and type "ntpd start" I get a response "ntpd: unknown user _ntp"
I suspect I have to do something to the ntpd.conf file but am struggling to see what.
asked Oct 9, 2014 in Linux by digiDave New to the Community (20 points)

Please log in or register to answer this question.

3 Answers

0 votes
do you have file /etc/ntpd.conf ?
To run ntpd you additionally need to:
echo "ntp 123/udp" > /etc/services
mkdir /nowhere
did you try to run ntpd -d?
take a look at this thread and try what is suggested there:
https://forum.openwrt.org/viewtopic.php?id=285

If it doesn't let me know and i will look deeper in to this
answered Oct 10, 2014 by LeonidM Veteran of the Digi Community (3,503 points)
0 votes
Hi Leonid,
Tried everything I can think of vis:
added: echo "ntp 123/udp" > /etc/services
added: mkdir /nowhere
still get ntpd: unknown user _ntp in response to either ntpd start or ntpd -d
then added _ntp:x:501:501:ntpd:/nowhere:/noshell
to passwd file, if I cat /etc//group file get _ntp:x:501:
and I now get the following response to ntpd -d:
fatal: bad privsep dir permissions: No such file or directory
dispatch_imsg in main: pipe closed
Terminating

Am now going to see if I can find the ntp.c source to search for the fatal error
answered Oct 15, 2014 by digiDave New to the Community (20 points)
0 votes
Okay, found the following in the ntp.c file:

if(stb.st_uid != 0 || (stb.st_mode & (S_IWGRP|S_IWOTH))
!= 0)
fatal("bad privsep dir permissions")

but I have no idea how to fix this!
answered Oct 15, 2014 by digiDave New to the Community (20 points)
...