Home/Support/Support Forum/Two way unicast using ZB mesh.

Two way unicast using ZB mesh.

0 votes
I am trying to implement two way communication between two Series 2 ZB modules, one set as Coordinator API and the other set as Endpoint API using the next get XCTU.

When I send unicasts from the endpoint with the destination address set to the coordinator address (0x00000000) they arrive fine. Same if I set it to the MAC of the coordinator.

If I send unicasts from the Coordinator with the destination address set to the MAC of the endpoint they don't arrive. Nothing is shown in the console for the endpoint. If I do the same with a broadcast destination address (0x00 00 00 00 00 00 FF FF) it arrives at the endpoint fine.

I'm not sure what config options would be relevant so say what you need to know and I'll provide. Thanks in advance for help.

// Robb GG
asked Oct 27, 2014 in RF Solutions and XBee by RobbGG New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
Try making sure that the SO, SN and SP, of the end device match the same values on the Coordinator. Also make sure that they are on the same channel (CH).
answered Oct 28, 2014 by mvut Veteran of the Digi Community (11,298 points)
0 votes
If you are in API mode you should get a TX status frame in response (if not change your frame ID to a non-zero number.) The status will tell you a lot about why the transmission is not arriving.
answered Oct 28, 2014 by jeremy Veteran of the Digi Community (471 points)
...