Home/Support/Support Forum/i.MX53 Flash WCE7 image from USB
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

i.MX53 Flash WCE7 image from USB

0 votes
Hi,

OK, I'm running out of ideas. I’m working on a CCWi-i.MX53 JSK. What I’m trying to figure out is - as you might have guessed - to flash a WCE image from an USB stick.
Based on
http://www.digi.com/support/kbase/kbaseresultdetl?id=3305
and
http://www.digi.com/support/forum/40385/mx53-jsk-with-windowc-how-boot-new-wce-from-microsd-using-uboot
my best guess is to either just
dboot wce usb 0:1 fat wce-CCXMX53
or setting the U-Boot command like
setenv bootcmd dboot wce usb 0:1 fat wce-CCXMX53
saveenv
reboot


None of the methods works for me. I’m getting:
Unknown command 'usb' - try 'help'
command usb reset failed


I’m using a freshly formatted FAT32 USB stick with only the wce-CCXMX53 file on it, in either of the J10 USB plugs.

Any help will be greatly appreciated. Thanks in advance

Sidenote: dboot usage:
CCWMX53 # ? dboot
dboot - Digi modules boot commands

Usage:
dboot <os> [source] [extra-args...]
Description: Boots <os> via <source>
Arguments:
- os: a partition name or one of the reserved names:
linux|android|wce|netos|eboot
- [source]: tftp (default)|flash|nfs|usb|mmc|hsmmc|sata|ram
- [extra-args]: extra arguments depending on 'source'

source=tftp|nfs -> [filename]
- filename: file to transfer (required if using a partition name)

source=usb|mmc|hsmmc|sata -> [device:part filesystem] [filename]
- device:part: number of device and partition
- filesystem: fat|vfat|ext2|ext3
- filename: file to transfer

source=ram -> [image_address] [initrd_address] [initrd_max_size]
- image_address: address of image in RAM (default: linuxloadaddr, netosloadaddr, etc)
- initrd_address: address of initrd image (default: loadaddr_initrd)
- initrd_max_size: max. allowed ramdisk size (in kB) to pass to the kernel (default: kernel default)

If <os> is 'wce' the following bootargs are possible:
cleanhive
asked Nov 11, 2014 in Windows CE by Viking New to the Community (2 points)
edited Nov 11, 2014 by Viking

Please log in or register to answer this question.

3 Answers

+1 vote
 
Best answer
Hello Viking,
In reviewing the uboot referenced manual, link below I found this note right below the "cleanhive" command. Looks like is not supported on i.MX53.

USB media is not supported in ConnectCore Wi-i.MX53 and ConnectCore i.MX53 platforms.

http://ftp1.digi.com/support/documentation/90001129_B.pdf
answered Nov 19, 2014 by Campbell Veteran of the Digi Community (694 points)
selected Nov 20, 2014 by Viking
Thanks a lot for taking the time to investigate this. Although this was not the answer I was hoping for :-) Oh well ... back to the drawing board.
0 votes
source=usb|mmc|hsmmc|sata -> [device:part filesystem] [filename]
- device:part: number of device and partition
- filesystem: fat|vfat|ext2|ext3
- filename: file to transfer


__________
prince
answered Nov 24, 2014 by salman123 New to the Community (3 points)
0 votes
source=usb|mmc|hsmmc|sata -> [device:part filesystem] [filename]

__________
prince
answered Nov 24, 2014 by salman123 New to the Community (3 points)
Hi, year that was what I came up with also. Thanks anyway. As Campbell stated, USB media is not supported in ConnectCore Wi-i.MX53
...