Home/Support/Support Forum/Ethernet link in ConnectCore 6 SBC
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Ethernet link in ConnectCore 6 SBC

0 votes
Dear all,
I am quite new to Android and Digi and I find problems to download samples from "Digi ESP for Android" development tool to the ConnectCore 6 SBC.
I am able to configure the setting for the ethernet in Android OS but when I try to connect with the SBC I always get the same error "Could not connect with debugging link"
When I write busybox ifconfig in the serial link, I get the following for eth0:
eth0 Link encap:Ethernet HWaddr 00:40:9D:7D:CF:B8
inet addr: Bcast: Mask:
inet6 addr: fe80::240:9dff:fe7d:cfb8/64 Scope:Link
RX packets:932 errors:0 dropped:0 overruns:0 frame:0
TX packets:249 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:161804 (158.0 KiB) TX bytes:10674 (10.4 KiB)

In the Android Devices window I configure a Network Device with IP address
What am I doing wrong?
Thank you very much for your help.
asked Nov 14, 2014 in Android by almarto New to the Community (3 points)

Please log in or register to answer this question.

1 Answer

0 votes
It seems like the output normally,which version ESP 2.0 or 2.1?
I suggest you config all the project under the ethernet configuration on the android OS.
answered Nov 17, 2014 by superf4ur New to the Community (25 points)
Thank you very much for your answer.
It is version 2.1. I already configure the ethernet port in android OS.
I don't honestly know how to configure DNS1 and DNS2 ... Actually, I have invented these values. I have configured the following:
IP adress
Gateway address
MAC adress is the correct one, as it appears on the module.
PC connect to CC6 SBC directly? if so, what is the PC IP address? the PC IP address must not DNS you can set to
all of this could not slove the issue,maybe you need to contact you local FAE of Digi, he will give you the newest version of Android OS.

The problem is solved! I had a stupid mistake in the IP static definition in my computer, so obvious that I could not see it ;-))
Thank you very much for your feedback superf4our.