Home/Support/Support Forum/Communication between 1 Xbee Wifi S6B and a TCP server running on PC.

Communication between 1 Xbee Wifi S6B and a TCP server running on PC.

0 votes
Hello everyone,

I bought few Xbee S6B module. Configured two of them in XCTU with the correct destination address.

Use cases:
1. Taking 2 xbees, works fine, setting the source IP of one as the destination IP of the other.

2. Now if I take 1 Xbee, set it's destination address as that of my PC and run a simple TCP server like netcat in Linux or HW-Hercules in windows, I am not able to establish any communication.

NB: Connecting and listening port is 5000, Infrastructure (WPA2 personal) and both devices on the same network, IP Protocol: TCP, Transparent mode: Just sending a "helloworld" message periodically. Configurations done in X-CTU.

Can anyone please help me to demystify this? I have to wok on a http server later but first I wanted to put my basics straight. Is there any sniffer tool to check data transmitted from the xbee.?

Thanks,
Gaurav
asked Jan 7, 2015 in IEEE 802.11 (Wi-Fi) by gauravptalukdar89 New to the Community (1 point)
edited Jan 7, 2015 by gauravptalukdar89
are you resolve the problem? same problem i am facing now i am sending simple unix time request to local server through XBee module ... but its not working

Please log in or register to answer this question.

1 Answer

0 votes
Check the Destination and Source port numbers on the XBee. They need to be set to the ports you are listening to on your Server for it to work.
answered Jan 7, 2015 by mvut Veteran of the Digi Community (12,786 points)
...